Rendering for BluRay

  • I still have clients who want BluRay disks. I have tried checking the BluRay compatibility box in Voukoder dialog, but even with that set, rendered output is re-rendered by my BR authoring program. I use TMPGENC Authoring Works, version What setting should I use to eliminate the re-rendering?

    Thank you in advance.

  • Vouk

    Approved the thread.
  • Are you using NVENC or x264 for encoding? I can give you example settings for both. Are you trying to import 720p or 1080p? Frame rate?

    Note that the TMPGEnc "RE" marker will appear for all files that it can't use directly. You can left mouse click on the RE and an info box will come up to show what video stream parameters are not compatible, then adjust the Voukoder setting accordingly. Most common is to ensure you're at level 4.0 ML/HP.

  • avwtp, thank you.

    I would like to try both NVENC and X.264. If you would please share the settings for both, I would truly appreciate it.

    [edit] I have a 2.5 hour program, so have to set the bitrate properly.

    Edited once, last by dxdy: Added bitrate info ().

  • avwtp: Sorry, that was a long layoff.

    I use Magix Vegas, not Premiere. Could you please do a screenshot of your Voukoder settings for BluRay in TMPGENC?

    Thank you,


  • Attached are screenshots of NVENC and x264 setups that import correctly into BluEditing Sw like TMPGEnc. Note that NVENC is for 29.97/30 fps and x264 is for a 23.974/24 fps projects.

    Hope this helps.

  • In the Preset dropdown, I don't have a Bluray option. Just 7 speed options from Slowest to Fastest. Tried rendering using the other NVENC settings as shown, and Architect Pro doesn't even recognize the resulting file as a valid video file . . . although it'll read the audio track.

    GPU is 2080Ti, Compute Capability 7.5, Voukoder 12.1, Vegas Pro 15, Architect Pro 6.0.

    Looking for a way to get Blu-Ray AVC/MP4 output that's compatible with Architect Pro without re-encoding.

    Edited once, last by Joe24 ().

  • I don't understand. Just switch over to the Options tab, ignore the Presets, and select as indicated. If BluRay option isn't set in options, won't work. Only way that "Slice" gets set correctly for NVENC.

  • Tried everything I could think of, finally gave up on Architect Pro 6.0 compatibility, switched to TAW (TMPGEnc Authoring Works 6). If TAW isn't happy about something, it'll at least tell you why. Plus if you want to create a DVD from the same project, TAW has hardware MPEG-2 transcoding built in, so it's very easy to make a DVD from an existing Blu-ray project. Have had good success with hardware-encoded files (Voukoder + NVENC) being accepted by TAW without needing re-encoding.

    You don't need all of @avwtp's bells and whistles above to get Blu-ray compatibility. The main things are: h.264 format, Blu-ray Compatibility enabled, GOP max 48 (for 23.976/24p video) or max 60 (for 29.97/30p video), CABAC encoding, Level 4.0 (technically 4.1 is allowed by the Blu-ray spec, but I find TAW won't accept Level 4.1 video), resolution/framerate within Blu-ray specs, and YUV420P color format.

    Other than the settings listed above, the rest is just playing with encoder settings to get your desired picture quality or render speed. You should be able to leave everything else at default and still get TAW-compatible renders. If you screw anything up, TAW will tell you what you did wrong.

    The attached photo is a very barebones configuration that should be TMPGEnc / Blu-ray compatible. The bitrate is really low, so you'll probably want to raise that (this project involved putting 19 hrs of video onto a single disc).

    Edited 11 times, last by Joe24 ().

  • Thank you AVWTP and Joe24. I used the settings in joe24's post, and while I couldn't find a setting for CABAC, it came out that way and TAW was happy. What a timesaver.

    Fred :)

  • I couldn't find a setting for CABAC

    Then I'm guessing your particular GPU only does CABAC encoding.

    Just did a test because I was curious, and it seems that TAW will also accept CAVLC encoding.

    What was probably messing you up last time is the Group-of-Pictures max size (GOP). Most encoders have a really large value by default, mine is 300. For Blu-ray though, this number has to be manually limited to 48 or less (for 24p video).

    Just to clarify, feel free to experiment with the other settings, as you can tweak your picture quality and encode speed quite a bit. @avwtp's settings will probably give you a much better picture than mine. But the settings that are absolutely critical to Blu-ray compatibility are listed in my last post.

    Edited once, last by Joe24 ().

  • Here's how to check in TAW6 whether your source file is compatible or not :

    Note that TAW6 uses fields, not frames, to indicate it's max GOP size. Voukoder "48 frames" = TAW6 "96 fields".

    Edited 3 times, last by Joe24 ().