Voukoder 6 doesn't see NVENC (GF 760, Win 7 x64, latest drivers), but Voukoder 5 does

  • Well, it's all in the title. Adobe Premiere and Media Encoder can't use NVENC with Voukoder 6 on my PC. I was using Voukoder 5 with premiere connector 1.4.0. NVENC was in place, but voukoder started to show tooltips "new version available". I updated drivers to 452.06 coz in release note there was limitation of nvenc to driver version 450 and newer. Then I installed connector 1.5.0 (without uninstalling 1.4.0) and Voukoder 6 (also without uninstalling 5). Now NVENC is gone. It's strange... Maybe I'm missing something?

    P.S. I uninstalled Voukoder 6 and installed 5. Premiere connector 1.5.0. Now everithing is fine, NVENC is in place. So there is some strange problem with new version of Voukoder and my old videocard:) And maybe Windows 7.

    And another addition, I've found log files! Not so much info in them, but there is something.


    So there is clearly problem with NVENC, Voukoder 6 and my PC

  • Thanks for answering! I've ran another test, with ffmpeg 4.3.1. Here is my command

    Code
    ffmpeg -i "DSCF6533.MOV" -c:v h264_nvenc -preset hq -profile high -cq 20 "DSCF6533.mp4"

    Everything is fine, ffmpeg 4.3.1 sees NVENC and encoding.

    P.S. GF 760 is still supported, here is the link

    https://developer.nvidia.com/v…decode-gpu-support-matrix

    On the bottom there is green button, to see all supported Geforce videocards:)

    I'm ready to provide more logs, like internal ffmpeg logs, if there are any:)


    I'll try to reinstall drivers and voukoder this way:

    • uninstall Voukoder and connectors
    • uninstall nvidia drivers
    • reboot
    • install nvidia drivers
    • reboot
    • install Voukoder and connectors

    I'll write here results.

  • Nah, it's useless, after all reboots and reinstallations voukoder 6 simply doesn't see NVENC.

    BUT! If I select previously created profile with NVENC in media encoder, it encodes just fine!

    So it's probably detection error in Voukoder itself.

  • Auch ich muss von Voukoder 6 auf 5 wieder zurück, da NVENC nicht mehr in der Auswahl aufgeführt wird,

    weder in Vegas noch in Premiere connectors.

    Meine Nvidia GeForce GTX 650 wird in Voukoder 6 nicht mehr erkannt!

    In Voukoer 5 ist alles OK!

  • Vouk

    Added the Label In Progress
  • Vouk

    Removed the Label Adobe Premiere / MediaEncoder
  • Nein, auch bei 6.1.b kein NVENC anwählbar!

    In 6Vouk muss sich was gravierendes geändert haben, was die Nvidia GPU betrifft!

    Wie gesagt, in Vouk 5 funktioniert alles bestens mit Vegas oder Premiere Connector.

    Die mit Version 5 erstellten Vorlagen werden von Version 6 komischerweise voll übernommen.

    Ich werde deshalb wieder auf Version 5 zurück gehen!

  • Maybe some old saved profiles of Voukoder cause this? Can you try to delete all saved profiles in Premiere/Media Encoder?

    It's really not about profiles in Adobe, I was testing it in VirtualDub, it's the same.

    Is it fixed in this version again?


    http://www.voukoder.org/_download/voukoder-6.1.msi


    What about this one? Built with SDK 9.0. This should work with GPUs down to Kepler.


    http://www.voukoder.org/_download/voukoder-6.1b.msi

    Both are not working, sad... And thanks for all your great work! By the way I wish to thank you for VirtualDub with Voukoder, with ffmpeg import and vobsub plugin for subtitles it become ultimate solution for encoding practically everything! Thanks!

  • Die unter Vouk 5 angelegten NVENC Vorlagen werden in 6.1 angenommen und gerendert!

    Do you mean NVENC basically works when using an existing preset, but the encoders are just not listed?


    Maybe somebody else can test this, too

    1. Create an NVENC profile/preset with Voukoder 5
    2. Update to Voukoder 6 (NVENC is not available)
    3. Load the NVENC profile/preset and try to export with it
  • Ja genau, ich hatte vorher mit Vouk 5 gearbeitet und mir auch verschiedene Voreinstellungen (Profile) angelegt.

    Ich habe dann Vouk 6 installiert und wollte ein neues NVENC Profil erstellen

    und hatte dabei festgestellt, dass der NVENC nicht mehr in der Codeaufstellung vorhanden ist.

    Dann habe ich mit Vouk 6 ein von Vouk 5 vorher erstelltes Profil aufgerufen und konnte damit rendern. Ich habe mich gewundert, das Vouk 6 mit einem

    Codec arbeitet, den er gar nicht gelistet hat.

    Fakt ist, dass Vouk 6 kein NVENC installiert hat der auch abrufbar und einstellbar ist. Dennoch vielen Dank Vouk für Deine großartige Arbeit!

    Den Teufef wirst Du schon noch austreiben!

  • Please try this:

    1. Make sure low level logging is enabled
      pasted-from-clipboard.png
    2. Download and install this: https://www.voukoder.org/_download/voukoder-6.1c.msi
    3. Start up your app and check if the encoders appear or not (it's okay if they don't appear)
    4. Open the explorer and go to %LOCALAPPDATA%\Voukoder\Logs
    5. Open the log file with todays date and copy it to the forum / send it to me.
      This file should contain the reason why an encoder could not be loaded

    Sorry, that it's so complicated but unfortunately I don't have such video card.

  • Hallo Vouk, ich glaube Du hast den Teufel gefunden,

    Nach Install von Vouk 6.1c kann ich den NVENC aufrufen und verwenden.

    Ich habe versucht auch die logdatei zu übertragen.


    Vouk 6.1.c.png




    Benötigen Sie eine benutzerdefinierte Encoder-Lösung / Plugin? Kontaktieren Sie mich .


    Helfen Sie, dieses Plugin zu verbessern und unterstützen Sie mich auf Patreon oder Paypal . Danke dir.

























    Werbung
































    Benötigen Sie eine benutzerdefinierte Encoder-Lösung / Plugin? Kontaktieren Sie mich .


    Helfen Sie, dieses Plugin zu verbessern und unterstützen Sie mich auf Patreon oder Paypal . Danke dir.

























    Werbung

  • Do you mean NVENC basically works when using an existing preset, but the encoders are just not listed?


    Maybe somebody else can test this, too

    1. Create an NVENC profile/preset with Voukoder 5
    2. Update to Voukoder 6 (NVENC is not available)
    3. Load the NVENC profile/preset and try to export with it

    Yeah, as I said before, you can export with NVENC, using previously created media encoder profiles. It's just you can't see NVENC in the list, but you can export with it.

    Please try this:

    1. Make sure low level logging is enabled
      pasted-from-clipboard.png
    2. Download and install this: https://www.voukoder.org/_download/voukoder-6.1c.msi
    3. Start up your app and check if the encoders appear or not (it's okay if they don't appear)
    4. Open the explorer and go to %LOCALAPPDATA%\Voukoder\Logs
    5. Open the log file with todays date and copy it to the forum / send it to me.
      This file should contain the reason why an encoder could not be loaded

    Sorry, that it's so complicated but unfortunately I don't have such video card.

    Oh, well, let's do it!

    Installed 6.1c - check.

    VirtualDub 1.10 with voukoder. I can see all hardware codecs, like AMD (I have Intel) and QSV (I have old intel 2600k without QSV). And NVENC also visible. Attached screenshot.


    First attempt to export video - alert window "error in Voukoder", failed. Attached log1.txt


    Second attempt to export - success! Attached log2.txt


    Third attempt - success! Attached log3.txt


    So, 2 of 3, it's working somehow:)

  • Unfortunately I had a typo in the code that made all encoders appear. *sigh*


    But it seems log3.txt showed the error:


    Code
    [19:39:31] FFmpeg: Lossless encoding not supported


    When testing the encoders for availability it uses a default setting that wants to encode in a lossless mode. This is not supported with the old GPUs and that's why it fails. Seems it was introduced with FFmpeg 4.3.


    Working on it.