For Vegas darker renders, is a solution possible to solve this?

  • Ok the output is still dark like the screenshots above, when using the new color space filter with:

    --range tv --colorprim bt709 --transfer bt709 --colormatrix bt709


    It seems like its a vegas problem, like steve said, because the only "encoder" who isnt that dark is x264vfw, but i don't know why.


    My knowledge is way to limited, but i know that vegas is converting all video inputs to rbg ... maybe thats a problem?


    This describes the problem exactly: https://forums.creativecow.net…univpostid=983265&pview=t


    So i think i need to apply the "levels" filter everytime :/

  • Hey dream, the solution is very easy, (finally a decent solution that i have been looking for, for many years now to combat this Vegas issue).

    In the Voukoder configurations, in the "Filters" tab, Select "Equalizers" and select

    Gamma and set the value to 1.2 and then Gamma Weight and set it to 1.0

    Now save this setting as a render preset, so now all your renders will look exaclty how it is

    in your Vegas preview window

  • I did not want to add anything to this discussion anymore but It's itching me pretty hard right now:


    This is the original document I once sent to Magix explaining them the preview is broken (in most cases). This behaviour has been confirmend by Magix.

  • So i tested some thing with FFMPEG and with this parameter i get the correct colors:

    Code
    ffmpeg -i "G:\test.mkv" -vf "scale=in_range=pc:out_range=tv" -pix_fmt yuv420p -c:v libx264 -preset ultrafast -crf 21 Output.mkv

    But this is only for a already encoded video with Vegas, because Vegas somehow set the pc range flag?

    So the solution is to tell the encoder that the input is in pc range if i understand the filter correct:

    -vf "scale=in_range=pc:out_range=tv"


    When i try to encode directly from the source file (No encoded Video from Vegas) i need to the the filter to:

    -vf "scale=in_range=tv:out_range=tv" (It depends on the source file).



    I don't know if this is possible to implement and if this is even the correct fix for this problem.

  • Here I solved this issue using the SeMW extension (free). Enable its Preview levels extension (Tools menu > Extensions), which will put a new dropdown menu above the Vegas preview window. In that dropdown menu choose "PC". You can safely render with that set, as it applies to preview only.

    https://www.semw-software.com/en/extensions/


    More information can be found in this Vegas forum thread.

    https://www.vegascreativesoftw…he-vegas-preview--104567/

    https://www.vegascreativesoftw…--108969/?page=2#ca671873

    https://www.vegascreativesoftw…on-test--111385/#ca688280

  • That is not the effective solution to what we are trying to resolve here!

    Actually we're discussing any possible solution here. I want to fully understand this issue.

    Input

    I opened "bars.mp4" in MPC-HC, took a still image ("Reference") and here it is:


    Preview

    I imported it to VEGAS Pro 17, dragged it to the timeline, saved a still image ("Preview") from VEGAS and pasted it here:



    What we all notice:

    • White is not as bright as the white in the Reference
    • Black is not as black as in the Reference
    • Gray is brighter than in the Reference

    As the Preview is not equal to the Reference I consider it as ...

    • ... the colors of the Preview are brighter than the Reference
    • ... the VEGAS preview is broken as it does not show the source video correctly

    Output

    I will now render it with Magix' very own encoder by clicking "File" > "Render as" and selecting format "MAGIX AVC/AAC MP4" and preset "Internet HD 1080p 59,94 fps". I get a new mp4 file, open it with MPC-HC and save a still image ("Output") from it:



    Exporting it with Voukoder looks like this:


    Conclusions

    • Reference is not equal to the Preview => Preview is not okay!
    • Output is equal to the Reference => No issue with rendering / exporting!

    Whats left is that the preview is not okay:

    • ... which has been confirmed by MAGIX
    • ... SeMW tools have been developed to fix this

    I don't see any other issues. If I did something wrong or miss anything please tell me. Do your own tests with the bars.mp4 file attached to this post and help me to understand this (if I didn't).


    But please, from now on: Let's discuss this with facts and measurements only!


    P.S.: This has been done entirely in 8-bit mode.

    Files

    • bars.zip

      (43.38 kB, downloaded 45 times, last: )

    Help to improve this plugin and support me on patreon or paypal. Thank you.

  • Okay with the bars.mp4 i get the correct output.


    When the source is from UTVideo or MagicYUV (.avi lossless formats) i get the dark output.

    I tried to record with Dxtory, MSI Afterburner and OBS Studio (OBS uses the FFMPEG Version of UTVideo).


    Steps to reproduce with MSI Afterburner:

    Software

    Install utvideo-20.3.0 (Newer Versions have problems with dxtory, vegas and afterburner)

    Install MSI Afterburner with Rivatuner Statistic Server


    Afterburner

    Open MSI Afterburner Settings > Video Recording (Videoaufnahme)

    Screenshot with the settings: https://i.imgur.com/tnMpFPC.png

    I also tried different colors for UTVideo like: 4:2:0, 4:2:2 and RGB


    Rivatuner

    In Rivatuner Statistic Server i make sure, that the

    • Global Profile Application detection level is set to low
    • On-Screen Display support: On
    • On-Screen Display coordinate space: Framebuffer


    Setup/Settings in Rivatuner:

    Use dedicated encoder service > 64 Bit


    Record a random Game


    Vegas Pro:

    ...Import the video

    Project settings

    I use Vegas Pro 15 with these project settings: https://i.imgur.com/zvPzk3f.png


    Render as

    For example Voukoder with H.264 (x264):

    crf=20.0 preset=medium profile=high rc=crf


    EDIT:

    Also make sure to use the full dynamic range for videos in the NVIDIA control panel video tab > Adjust video color settings > With the NVIDIA settings > Advanced > Dynamic range : Full (0-255)

    Edited 3 times, last by dream ().

  • I created two AVI clips with BandiCAM & MagicYUV 2.2:

    Reference Preview Export
    Limited
    Full


    It's a bit strange that the "Full" color range now looks strange in the preview but the result looks okay in both cases.


    dream I will try to reproduce your exact scenario tommorrow. I still recommend using the "Limited" color range when using YUV. The footroom and headroom is used by some cameras for super-black / super-white. I've read this was a reserve in the good old analogue TV times.

    Help to improve this plugin and support me on patreon or paypal. Thank you.

  • Joelson, We all know about that!

    That SeMW extension has been discussed here already, even so.

    That is not the effective solution to what we are trying to resolve here!

    1.This is a Vegas problem, not Voukoder.


    2.This problem has existed in Vegas for several years and developers are fully aware of it, but seem not to be interested in solving it.


    3.Even if Vouk develops a definitive solution when using Voukoder, the problem will still continue when using other codecs.


    4.So far, the SeMW extension is the most efficient solution to this problem. You just need to know how to use it in conjunction with FX Levels Studio RGB to Computer RGB that exists natively in Vegas.


    5.Resolving this issue is the responsibility of the official Vegas developer, not the Voukoder developer.


    Thanks Vouk for the Equalizer filter

    I close here my participation in this topic.