Posts by dream

    Mit der neuen Version, besteht das Problem bei mir nach wie vor.


    Thank you!


    With Voukoder 2.3 my lossless avi files get the correct colors, because i can use this code from ffmpeg in voukoder:

    ffmpeg -i "G:\test.mkv" -vf "scale=in_range=pc:out_range=tv" -pix_fmt yuv420p -c:v libx264 -preset ultrafast -crf 21 Output.mkv


    Now i get the correct colors in the output with

    1. .mp4 videos that i record with nvenc (There were always correct, so no need to use a filter)
    2. Lossless .avi (magicyuv, utvideo) files recored with dxtory, obs etc. when i use the Voukoder filter colorspace.


    colorspace filter setting for lossless .avi files recored in limited range:

    Output

    • Range: Limited
    • Matrix: BT.709
    • Primaries: BT.709
    • Transfer: BT.709

    Input:

    • Range: Full (The important one)
    • Matrix: BT.709
    • Prismaries: BT.709
    • Transfer: BT.709


    Thank you for your excellent work and fast responses.

    Instead of adding -b:v 0 a simpler "fix" would be to allow these values to be set to 0, what give me the correct result, when i'm testing in FFMPEG:

    bits.jpg


    FFMPEG Example:

    Sorry to bother you again, but in order to use qmax and qmin without bitrate limitations, you need the parameter: -b:v 0


    You can test that in ffmpeg with the following code:

    ffmpeg -i "yourinput" -vcodec h264_nvenc -preset hp -profile:v main -rc:v vbr -b:v 0 -qmin 10 -qmax 16 Out.mkv


    If you remove -b:v 0, ffmpeg will always use a constant qc value, but with -b:v 0 set ffmpeg/nvenc can use a lower value (qmin) for scenes that are more complex (more quality).


    In ffmpeg you can see the current used value while encoding:ffmpeg.jpg

    Bei der 2.3b4 werden jetzt zwar die erweiterten Einstellungen bei x264/265 korrekt angezeigt, aber nur die vom letzten Aufruf des Codecdialogs! Wenn man ein zuvor abgespeichertes Preset (bzw. eine "Voreinstellung") lädt, stehen die alten Einstellungen noch im Fenster drin und nicht die des Presets. Das Problem besteht jetzt übrigens auch beim nV-Encoder.

    Daß das Laden der Voreinstellungen endlich mal richtig klappt, wäre schon 'ne richtig gute Sache!

    Same thing for Vegas Pro 15 with 2.3b5

    This time i recorded with Dxtory but it shouldn't matter, because i used UtVideo YUV420 BT.709 VCM.

    Mediainfo from reference (Source):

    In the table view i try to demonstrate the problem with Vegas and lossless .avi files (i don't know if something else is also affected)


    Notice: These are the NVIDIA Control Panel settings i normally use, for this test i switched between limited and full and show the results in the table:


    Reference (.avi UTVideo 4:2:0 BT 709) Software x264 Output
    Limited (16-235)
    (NVIDIA Control Panel)
    x264 Output
    Full (0-255)
    (NVIDIA Control Panel)
    vegas_source.jpg Vegas Pro 15 vegas_limited.jpg vegas_full.jpg
    ffmpeg_source.jpg FFMPEG ffmpeg_limited.jpg ffmpeg_full.jpg


    Vegas Pro 15 output


    As you can see the output from Vegas Pro 15 is "much" darker when full range is enabled in the NVIDIA Control Panel.

    This can be fixed by applying the Vegas Pro 15 filter "levles" > computer RGB to studio RGB.

    Then the Image would be bright on limited output, but would look like the source on full.


    Vegas Pro settings:

    Project settings and Voukoder settings are the same like in my comment about MSI Afterburner.


    Voukoder output mediainfo:

    FFMPEG and other software


    FFMPEG, MeGUI and x264vfw (Each software is able to encode with x264) handles videos like the images show above next to FFMPEG.

    On limited range the image is brighter and on full range its like the reference source, when you have a .avi source recorded in bt 709, limited range (like i said i don't know if something else is also affected)


    FFMPEG settings:

    ffmpeg -i "input" -pix_fmt yuv420p -c:v libx264 -preset medium -crf 21 Output.mkv


    FFMPEG mediainfo:

    Somehow x264vfw with Vegas can output the video correct, but the process is a bit more complicated to write down, why i choose ffmpeg as an example above...


    And again its not a Voukoder problem, but a Vegas Pro problem :)

    dream I will try to reproduce your exact scenario tommorrow. I still recommend using the "Limited" color range when using YUV. The footroom and headroom is used by some cameras for super-black / super-white. I've read this was a reserve in the good old analogue TV times.

    The problem with that, is when you upload that video to youtube, the video will also look "dark" if a user enables the full range in his browser/device or in the nvidia control panel.


    Like other people said, its a Vegas problem and the only solution at the moment, is to use the Vegas Pro level filter > Computer RGB to Studio RGB.


    Thanks for testing all that!

    Okay with the bars.mp4 i get the correct output.


    When the source is from UTVideo or MagicYUV (.avi lossless formats) i get the dark output.

    I tried to record with Dxtory, MSI Afterburner and OBS Studio (OBS uses the FFMPEG Version of UTVideo).


    Steps to reproduce with MSI Afterburner:

    Software

    Install utvideo-20.3.0 (Newer Versions have problems with dxtory, vegas and afterburner)

    Install MSI Afterburner with Rivatuner Statistic Server


    Afterburner

    Open MSI Afterburner Settings > Video Recording (Videoaufnahme)

    Screenshot with the settings: https://i.imgur.com/tnMpFPC.png

    I also tried different colors for UTVideo like: 4:2:0, 4:2:2 and RGB


    Rivatuner

    In Rivatuner Statistic Server i make sure, that the

    • Global Profile Application detection level is set to low
    • On-Screen Display support: On
    • On-Screen Display coordinate space: Framebuffer


    Setup/Settings in Rivatuner:

    Use dedicated encoder service > 64 Bit


    Record a random Game


    Vegas Pro:

    ...Import the video

    Project settings

    I use Vegas Pro 15 with these project settings: https://i.imgur.com/zvPzk3f.png


    Render as

    For example Voukoder with H.264 (x264):

    crf=20.0 preset=medium profile=high rc=crf


    EDIT:

    Also make sure to use the full dynamic range for videos in the NVIDIA control panel video tab > Adjust video color settings > With the NVIDIA settings > Advanced > Dynamic range : Full (0-255)

    So i tested some thing with FFMPEG and with this parameter i get the correct colors:

    Code
    ffmpeg -i "G:\test.mkv" -vf "scale=in_range=pc:out_range=tv" -pix_fmt yuv420p -c:v libx264 -preset ultrafast -crf 21 Output.mkv

    But this is only for a already encoded video with Vegas, because Vegas somehow set the pc range flag?

    So the solution is to tell the encoder that the input is in pc range if i understand the filter correct:

    -vf "scale=in_range=pc:out_range=tv"


    When i try to encode directly from the source file (No encoded Video from Vegas) i need to the the filter to:

    -vf "scale=in_range=tv:out_range=tv" (It depends on the source file).



    I don't know if this is possible to implement and if this is even the correct fix for this problem.