Vouk 2.2.0 REALLY Slow, 1.1.3 Still Quick (NVENC/HEVC h.265)

  • Hey gang -

    I have both 2.2.0 and 1.1.3 installed with Premiere, and I'm attempting to export a 25Mbit/sec 4K/59.94 video that's about 8 or 9 minutes long. I'm doing so with the HEVC hardware encoder on my 2080Ti card. When I use the older 1.1.3 plugin, it takes about the amount of time I'd expect; if the video is time t, the encoding/exporting is about time t. But with 2.2.0, when I hit the export button, it takes upwards of 2t if not longer.

    17:31:22] ---------------------------------------------

    [17:31:22] Export started

    [17:31:22] ---------------------------------------------

    [17:31:22] Frame size: 3840x2160

    [17:31:22] Pixel aspect: 1:1

    [17:31:22] Frame rate: 59.94

    [17:31:22] Interlaced: No

    [17:31:22] Color range: pc

    [17:31:22] Color space: bt709

    [17:31:22] Color primaries: bt709

    [17:31:22] Color TRC: bt709

    [17:31:22] Sample rate: 48000

    [17:31:22] Audio channels: 2

    [17:31:22] ---------------------------------------------

    [17:31:22] Opening codec: hevc_nvenc with options: b=25000000|bufsize=0|gpu=0|rc=cbr

    [17:31:22] Opening codec: aac with options: b=512000|profile=aac_main

    [17:31:22] Requesting pixel format: yuv420p

    [17:31:22] Applying video filters: colorspace=range=jpeg:space=bt709:trc=bt709:primaries=bt709

    [17:31:22] Frame #0: vRender: 97463 us, vProcess: 5 us, vEncoding: 22738 us, Latency: 120240 us

    [17:31:22] Frame #1: vRender: 187 us, vProcess: 4 us, vEncoding: 8948 us, aRender: 1415 us, aEncoding: 6 us, Latency: 10583 us

    [17:31:22] Frame #2: vRender: 34220 us, vProcess: 4 us, vEncoding: 8214 us, aRender: 70 us, aEncoding: 142 us, Latency: 42676 us

    [17:31:22] Frame #3: vRender: 16161 us, vProcess: 4 us, vEncoding: 8218 us, aRender: 85 us, aEncoding: 132 us, Latency: 24623 us

    [17:31:22] Frame #4: vRender: 32195 us, vProcess: 5 us, vEncoding: 8067 us, aRender: 70 us, aEncoding: 123 us, Latency: 40496 us

    [17:31:22] Frame #5: vRender: 16429 us, vProcess: 4 us, vEncoding: 8353 us, Latency: 24799 us

    [17:31:22] Frame #6: vRender: 33156 us, vProcess: 4 us, vEncoding: 8286 us, aRender: 73 us, aEncoding: 122 us, Latency: 41667 us

    [17:31:22] Frame #7: vRender: 16899 us, vProcess: 4 us, vEncoding: 8364 us, aRender: 74 us, aEncoding: 125 us, Latency: 25491 us

    [17:31:22] Frame #8: vRender: 33480 us, vProcess: 4 us, vEncoding: 8382 us, aRender: 73 us, aEncoding: 126 us, Latency: 42101 us

    [17:31:22] Frame #9: vRender: 14932 us, vProcess: 5 us, vEncoding: 8301 us, aRender: 74 us, aEncoding: 125 us, Latency: 23462 us

    [17:31:22] Frame #10: vRender: 34720 us, vProcess: 5 us, vEncoding: 8372 us, Latency: 43109 us

    [lots of stuff clipped]

    [17:32:10] Exported 1350 frames in 47 seconds. (avg. 28 fps)

    [17:32:10] Flushing encoders and finalizing ...

    [17:32:10] Video and audio buffers flushed.

    [17:32:10] Trailer has been written.

    [17:32:10] Closing encoders ...

    [17:32:10] ---------------------------------------------

    [17:32:10] Export finished

    [17:32:10] ---------------------------------------

    I usually cancel it out, which is why it doesn't run that long. It feels like it's trying to do a 2-pass for some reason, but I don't see that option anywhere in the plugin menus.

    I'm sure I'm doing something stupid here; any guess as to what it is?


    • Official Post

    There are many users reporting this. But I never found out why it is like that.

    When i use my test project (2048x1152 / h264_nvenc / default) version 2.3b2 is even faster than 1.1.3.

    All I know it has to do with the time premiere needs to render the raw frame (vRender). Did you try the VRPT tool on the project? Does that finish faster or slower than 1.1.3?

  • Did you try the VRPT tool on the project? Does that finish faster or slower than 1.1.3?

    I'll try that once I get home from work later today and report back. What confuses me a bit is why running it through 1.1.3 is so much quicker if it's a vRender issue? Wouldn't that affect both versions of the plugin?

  • I didn't manage to run the test all the way through. I started it up, saw that the estimated time went up to somewhere around 1.5t and let it go for a minute or two, then killed it. In other words: it's slower than 1.1.3, but a little faster than 2.2.0.

  • I can confirm what jasonvp wrote.

    I did tests with a 1-minute sequence (3840x2160 60p, cineform codec source; no fx or anything).

    With 2.2.0 (and 2.2.3) it exported in around 2:30 (basically 2.5:1 time ratio)

    Then I ran VRPT , and it completed with about 1.6:1 ratio:

    Finally, I've tried 1.1.3 and it finished in 51 seconds (0.85:1).

    I re-ran this several times, and even with different compression/profile settings, these numbers remained pretty much the same.

    My specs are i7-7700k@stock, 32gb ram, 1080Ti, win10. Source/export on fast disk (no bottlenecks).

    Thanks for your work and it's great projects like these exist; the speed of 1.1.3 export is a real incentive to use it over CPU encoding when time is a priority.

  • Vouk

    Added the Label In Progress
    • Official Post

    Finally! First user reports show that this issue is fixed when using the Premiere Connector 1.4.0 (or later).

    It took quite a long time but it seems the latest Voukoder versions are now quite as fast (or even faster) as Voukoder version 1!

  • Vouk

    Set the Label from In Progress to Fixed
  • Vouk

    Set the Label from Independent to Adobe Premiere / MediaEncoder
  • Wonderful! Thanks Vouk for fixing the Premiere connector. It is indeed as fast as v1 now. Also it's grown leaps and bounds since then, with match setting checkmarks, separate configuration window, etc. Looking forward to using publish tab, since with v1.1.3 I had to resort to timers & macros to make chrome upload file when it's done exporting. I'm glad you've added the default good quality preset, since I always forget which encoder preset/profile to use for that.

    Yep. I confirm it is as fast as Version 1, but the new H.264 native support is faster than Voukoder now.

    I can't quite get behind that, since for me they work at pretty much the same speed. The first thing when PP 14.2 came out I did was tested hardware encoding against vouk 1.1.3 , and now I've re-tested with vouk 5 with 1.4.0 connector. I only tested 1 minute as usual, both in media encoder and premiere, the encoding task finishes at roughly the same time.

    Interestingly, for me, Premiere native export takes longer time to assemble (finalize) the mp4 file, even though both PP and my vouk settings use faststart.

    At first I thought it can be due to bitrate difference that occurs due to the fact that I'm using CQP mode with vouk, but even with twice the bitrate, vouk finalizes test file faster. Maybe there's some extra time PP takes writing some metadata or processing something.

    This may be isolated to my test export, I can't statistically confirm it yet.

  • The native encoder renders both video and audio streams separately and then muxes it at the end to an mp4 file.

    Voukoder directly writes a muxed file.

    Oh right, indeed I noticed it write streams like that, one then another. Makes sense. Voukoder also spends time moving the faststart atom, but I guess it was faster on my short test export, I dunno. I know it pretty much depends on disk read/write performance at that point.