Voukoder 12

    • Official Post

    Release Notes

    Make sure you are using the latest connector for your application(s). For using NVENC (SDK 12) encoders driver version 520.00 or later is required. This has not been released yet!

    Fixes / Changes

    • Upgraded from FFmpeg 5.0 to FFmpeg 5.1
    • Adapted SVT-AV1 to new parameter interface and added CRF to rate control options
    • Video side data: Adjusted MDCV luminance limits (Min: 0-5, Max: 5 - 10000)
    • Switched to NVENC SDK 12
    • Added NVIDIA AV1 encoder for RTX 40 series GPUs

    Credits

    Thanks to my all supporters by either PayPal, Patreon or BTC (33wJ6Jg3KbZA4ZMJMQBFMh7jxWFAnad1Lp). Also thanks alot to the translators.

    Top Patrons

    Gronkh, Schauerland, Michael wooldridge and Chris Woods

    Download

  • SVT-AV1 and CRF seem to work fine. But is it normal for it to be noticeably slower than FFmpeg directly? Overhead coming from Premiere I suppose?

  • I just installed v12 beta 1 and the hevc_nvenc encoder I usually use is no longer available. All the hardware encoders, including QSV, have disappeared from the list.


    Windows 10, Adobe Media Encoder 2022, premiere-connector-1.11.1, GTX 1080, driver version 516.94


    Screenshot

    • Official Post

    Can you ...

    1. Enable "low level debugging" in voukoder settings
    2. Open Voukoder settings in premiere
    3. Send me the most recent log file in C:\Users\Daniel\AppData\Local\Voukoder\Logs
  • Log file with "enable low-level logging" active. I also ran a quick export in case that might show something interesting.


    2022-09-25.log - Pastebin.com
    Pastebin.com is the number one paste tool since 2002. Pastebin is a website where you can store text online for a set period of time.
    pastebin.com


    I see all NVENC encoders failing to initialize and the QSV encoders load, then unload.


    To confirm my system or drivers didn't somehow get messed up, I tested encoding with NVENC and QuickSync with OBS. Both hardware encoders worked properly.


    I also tested an encode using hevc_nvenc with FFMPEG itself through command line, which also worked.

    • Official Post

    NVENC

    We need to wait for NVIDIA to release the updated drivers (520.0 or later).

    I've updated the beta versions change log.

    QSV

    Can you try updating to the latest Intel video drivers?

  • Integrated graphics drivers were updated from 100.9955 to 101.2111. No QSV encoders are available in Voukoder

  • I don't know when it was last working. I haven't used QuickSync in Voukoder in a very long time, probably years.


    I went back to 11.3.2 and while hevc_nvenc works again, the QSV encoders aren't available either.


    Out of curiosity I went back to 10.0. This time QSV encoders throw an error.

    Like I said, I usually use hevc_nvenc, so I didn't notice QSV hasn't been available - possibly for a long time. I'm glad you've already solved QSV and I'll try V12 again after NVIDIA releases new drivers. Thanks for the help.


    Another question: is there a way to use hevc_nvenc in lossless mode with Voukoder? When I use FFMPEG in command line, I use -c:v hevc_nvenc -preset p4 -tune lossless but I don't see a way to set the tune option. The FFMPEG options string is at the bottom of the window, but can't be edited.

  • Vouk

    Changed the title of the thread from “Voukoder 12beta1” to “Voukoder 12 Beta”.
  • 2022-09-27.log

    Code
    [12:15:38] Loading: encoders/h264_qsv.json
    [12:15:38]   FFmpeg: WARNING: defaulting child_device_type to AV_HWDEVICE_TYPE_DXVA2 for compatibility with old commandlines. This behaviour will be removed in the future. Please explicitly set device type via "-init_hw_device" option.
    [12:15:39]   FFmpeg: Using D3D9Ex device.
    [12:15:39]   FFmpeg: Error initializing an MFX session: -3.
    [12:15:39] Unloading: encoders/h264_qsv.json
    [12:15:39] Loading: encoders/hevc_qsv.json
    [12:15:39]   FFmpeg: WARNING: defaulting child_device_type to AV_HWDEVICE_TYPE_DXVA2 for compatibility with old commandlines. This behaviour will be removed in the future. Please explicitly set device type via "-init_hw_device" option.
    [12:15:39]   FFmpeg: Using D3D9Ex device.
    [12:15:39]   FFmpeg: Error initializing an MFX session: -3.
    [12:15:39] Unloading: encoders/hevc_qsv.json


    A new NVIDIA driver was released today that I haven't installed, yet. But it's 517.48 and not 520 so probably won't make a difference here.


    Repeating the question from my previous post:

    Another question: is there a way to use hevc_nvenc in lossless mode with Voukoder? When I use FFMPEG in command line, I use -c:v hevc_nvenc -preset p4 -tune lossless but I don't see a way to set the tune option. The FFMPEG options string is at the bottom of the window, but can't be edited.

  • I explained how to do it on the Vegas forum here. Works the same way with Resolve 18 Studio. Win11 22h2 adds Specific Gpu to the Windows settings without reference to power saving.


    Btw, ffmpeg.exe v5 also works like that but only for decoding with Intel or Amd. Ffmpeg,exe ignores the Win setting for encoders which I detect from the command line like this:


    Code
    ffmpeg -encoders | findstr "qsv"
  • Any chance for -svtav1-params 'tune' ,'film-grain-denoise', or the weird 'superres-mode'?

  • Game Ready Driver 522.25 has been released. I installed it and tried 12 beta 4. The NVENC encoders supported by my GPU are available and working.


    QuickSync encoder initialization errors:


    One final thing: My question about the hevc_nvenc option "tune" that enables lossless encoding has been deliberately ignored and I acknowledge that.