Voukoder Will Not Render Using GPU Presets In Vegas Pro 20

  • Using Vegas Pro 20 Ver 326. Just testing out my new PC having a 29 second project with 2 short AVC video files from cell phone footage, with 5 jpegs over layed and cropped on top of videos with transitions from Vegas.

    I can render using Vegas Magix AVC/MP4 templates with GPU acceleration. When I go to render with Voukoder I can render with H.264. Then if i try to render with any GPU preset in Voukoder the render dialog box shows a render for about 2 seconds showing 100% of-MB. I am using a new RTX 4090 with latest Studio Drivers. I tried rendering in Voukoder with the Intel IGPU settings as I have a 13900K, and AV 1 render since the RTX has AV 1 codecs, but they will not render showing the same dialog box 100% of - MB. I apply the settings before trying to render with Voukoder.

    When I select the NVIDIA preset in Voukoder this is all that shows up in options "gpu=0 preset=p4 profile=main qp=23 rc=constqp"

    This is what shows up when Intel render templete is used "global_quality=25 look_ahead=1 preset=medium profile=unknown qscale=1"

    And this is what is in the options box when X264 is used

    "crf=17.000 noise_reduction=8 opencl=1 preset=medium rc=crf x264-params=qpmax=24:chroma-qp-offset=-2:aq-mode=3:aq-strength=0.800:rc-lookahead=110:keyint=480:min-keyint=3:bframes=11:b-adapt=2:ref=3:deblock=0:0:direct=auto:no-weightb=0:me=umh:merange=32:subme=10:psy-rd=0.77:0.22:no-chroma-me=1:trellis=2:no-fast-pskip=1"

    Is it something I am doing wrong? My old PC with a 3900X and Radeon Vll rendered with GPU acceleration in Voukoder.

    I have the latest stable version of Voukoder with the latest connector. I uninstalled Voukoder and reinstalled with no luck using the GPU renders. Thanks.

  • Vouk

    Approved the thread.
  • How to do I send log files? I have them saved on my desktop. But it will not upload to your site.

    When I render with Voukoder with any GPU enabled setting, nothing is written to the saved folder where the file should be written to. I also enabled Legacy AVC decoding along with legacy HEVC decoding and still no rendered file in Voukoder. I also tried with both disabled and still no render. Thanks.

  • I got it to work in Vegas Pro 20. I was testing out Resolve 18, and had both Resolve and Vegas installed on PC. Since I am sticking with Vegas I uninstalled Resolve, uninstalled Voukoder. I reinstalled Voukoder and the connector and it is working great now. Thanks

    Just donated to the project.

  • RTX 4090 support NVENC AV1, NVENC AVC & NVENC HEVC codec; i9 13900K supports SVT-AV1, SVT-HEVC, SVT-AVC codec. Generally are the worse quality & proprietary versions of their counter parts, AV1 codec is an exeception since the software encoder is still unreliable.

    Compatibility issues could come from an older video editing software, GPU/iGPU drivers, outdated video encoder at this point.

  • Tested v13 on my laptop and it works great with Vegas vp20. Tried all the qsv renders including vp9 to avi. Surprised to see the hevc accelerated renders yielding ffmpeg quality measurements comparable to x265. i9-12900hk, Nvidia 3060 gpu, Intel IrisXe igpu.