Posts by fifonik

    I've experimented a bit and tried to fix the offset in mp4 rendered with connector 0.5.1 using itsoffset ffmpeg option:

    Code
    ffmpeg.exe -i voukoder.mp4 -itsoffset 0.044 -i voukoder.mp4 -map 0:0 -map 1:1 -acodec copy -vcodec copy synced.mp4


    ffprobe synced.mp4:

    Code
    start_pts=1056
    start_time=0.022000


    However, the synced.mp4 file behaves in VP exactly like file rendered using connector 0.7.1: if so4 disabled (default in up to VP14) -- the audio stream shifted one frame behind comparing to when so4 is enabled (default in VP15+).

    So looks like the VP's decoders decode audio streams differently depend on the start_time stream information.

    I suspect that Happy Otter Scripts is also affected.

    As a result, you cannot actually fix this using the offset and the only way to fix it properly for VP is to add silence at the beginning or trim audio.


    In any case, current implementation looks better as audio shift is smaller.

    In my view the audio rendered in voukoder is 1 frame AFTER the original audio, just see that the peak of the audio signal is on the right, when compared to the original audio. This happens in mine and in your screenshot.

    Sure. But previously you said 'ahead', not 'after'. I said 'behind' == 'after'.


    Yes, I also have the new so4 decoder disabled in internal preferences as it does not work correctly with my AC3 5.1 audio streams.

    I'm confirming that when the so4 option is in default value (TRUE), the audio in mp4 file rendered with voukoder connector 0.7.1 is in sync with original audio.

    When the option is in non-default value (FALSE), the audio in rendered mp4 file is 1 frame behind.


    You do not need to re-render, just change the option, restart VP, put original an rendered on timeline & compare.

    With FFmpeg AAC only STEREO mode seems to be affected.

    In the topic I started (link above), I rendered to AAC 5.1 and it was also affected (source -- m2ts from camcorder with AC3 5.1).


    While comparing, I removed all audio tracks from project but front channel only for simplicity (otherwise it would be 16 audio tracks in comparison project: source, wav, Sony AVC, Voukoder -- a bit too messy) . However, other channels are also affected.


    I can upload project + source again if needed.

    Could you please have a look at this:

    https://www.dropbox.com/s/9vp3…20Audio%20Shift2.zip?dl=1


    In archive:

    - Source m2ts file

    - Simple project where I just dropped single file on timeline and delete all audio tracks but front one

    - Wav file that I rendered from the project

    - Two mp4 files rendered with Voukoder. One without atrim and one with atrim 0.044

    - Comparison project in which I dropped all these files


    =>

    atrim 0.044 audio shifted more ahead. This is predictable as if I understand correctly, atrim stand for Audio TRIM and so it is trimming a bit of audio at start and the rest of audio shifting ahead.

    For the project I need option to shift audio behind.


    Thanks.

    I do not know how this is possible unless you specified VFR in Voukoder options.

    VP cannot supply VFR to encoder and framerate specified in project settings is used.

    You should set 60 fps and enable resample in your project settings.

    If I understand correctly, this is already implemented in v4 ("Showing video and audio pages only if they are selected in the NLE")

    Thanks a lot.

    Could you advice, how the filter can be used for fix the described issue when audio is ahead of video?

    If I specify Start (in s), the audio will be further ahead. Negative values not accepted.


    Stare/End samples do not work ar all: as soon as I finished enter value it reset to 0.


    P.S. Voukoder 4.1 and Vegas Connector 7.0

    I'd prefer not to have this feature or to have option that I can switch the feature off :(


    I do not like when programs connecting to internet to check for updates and always switching this off if possible.

    Especially I do not like when it happens on startup as it slows program startup and brake normal workflow.

    I bet you have not checked all possible scenario for this. No internet? No/disabled NIC? Firewall? Proxy? Server not available? Certificate expire? Server moved? (No offence. But I've already seen so many bugs in checking for update implementations that I'm almost sure in this).

    So people will deal with many such errors because of the feature.


    I'd like to start Vegas and edit video. May be this time I'm NOT going to do any renders at all (I'm editing video almost every day, but rendering probably once a week). Or may be I will use other encoders this time (lossless, intermediate).


    Imaging that ALL plugins will do this. This would be nightmare as people will deal with all these update messages, but not with what they wanted to do.



    I believe that such feature should be not on startup but in Voukoder template. If no core installed -- error message. And button to check for update when pressed. I know that some other plugins implemented uuto update this way . I do understand if someone provide plugin pack. In this case it makes sense to have async process somewhere that will check is new pack is available instead of injecting it into all pack's plugins.

    When I render from Vegas Pro 17 with Voukoder/x264/AAC I see that in resulting file audio stream is ahead of video stream.

    If I render simple wav or using internal encoder audio and video are in sync.


    People in Vegas Pro forum mentioned that this is known issue and they have the same issue while rendering through frameserver + handbrake/x264/AAC: audio stream is 44ms ahead.

    Another option for render from Vegas using x264/AAC is Happy Otter Scripts and autor added workaround (ffmpeg option -itsofffset 0.0444) to deal with the issue.


    Is it possible to add option into Vegas connector to add audio offset (defaulted to 44ms) that can be used to deal with the issue?


    Thanks.