Failed opening codec using 2.3 beta 5 with Premiere conector

  • Installed 2.3 beta 5 with Premiere connector, the (connector) installer creates a PrmDIR inside Program files

    Premiere is unable to see Voukoder till I copy the prm file inside Plugins/mediacore

    here's the log:

    Voukoder core is installed on Program Files/Voukoder

    Running windows 10 LTSC

    packages installed:


    • Official Post

    1. The connector should let you choose the installation directory. The default value will be taken from the registry:

    C:\Program Files\Adobe\Common\Plug-ins\7.0\MediaCore

    2. Please make sure you have at least NVIDIA driver 418.81 installed

    3. What happens if you use x264 with default options?

  • Im running nvidia 431.36, running with default options does exactly the same, it doesn't matter what codec I chose, also, NVENC is never an option.

    Had 2017 and 2018 running together for a while, the installer always points to PrmDir, will try reinstalling the connector pointing to the right folder

    running with default options

    [08:24:13] Opening codec: libx264 with options:
    [08:24:13] Failed opening codec: libx264
    [08:24:13] Unable to open video encoder: libx264
    [08:24:13] Closing encoders ...
    [08:24:13] Opening encoder failed! Aborting ...
    [08:24:13] 000000006AB565A0
    • Official Post

    Really strange. I have the impression that it is somehow related to your specific windows configuration.

    Is it possible your user is a special restricted user? Maybe limited by various rules defined by a domain policy? Or in a citrix environment or similar?

  • Tried reinstalling the connector, it does the same.

    Well the user profile is not restricted in any way that I know of.

    Premiere tries encoding needed audio 1st and then it closes the Export settings window without any error, the log shows the exact same message.

    Could it be that part of the core is not getting installed correctly?

    • Official Post

    So, also strange one. According to the Premiere Developers Guide a key "CurrentVersion" should be present.

    I have no clue why it can't start a software encoder. Maybe you can run it in a debugger (i.e. windgb.exe) so you get important additional logging information in the output console.

  • OK, according to WinDBG my driver version comes with an older API in order to use NVENC, that can be easily solved with the lates drivers.

    windbg output attached


  • Im still unable to use any encoder, this only solved NVENC not being an option but x264, x265, VP9, any NVENC encoder just finishes in 0 seconds and does nothing

  • It does not show any error related to x264, it shows the program is loading voukoder.dll but that's it, I attached the log in one of my previous post, its quite large

  • The debug output does not include any Nvenc attempts to encode, just x264

    The nvenc tryout was made after I closed the debugger and tried again with updated drivers

    • Official Post

    Yes, I am not interested in NVENC anymore, we have found the reason for it. I'd like to know why other encoders are failing now.

    That's why I asked you to test any other encoder (i.e. x264). As it is failing with an error in the voukoder log there must be some FF low level log entries.

    I can't help you if you don't want to send it to me.

  • I've been manually setting it to match source as doing it from the button sets it at 5 fps...

    I just manually changed back to 60, but I've done it before, for some reason it's working... will let it finish and close windbg and try again

    EDIT:: Ok, from what i'm seeing, if I modify the codec parameters, it fails to encode, but leaving everything at defaults and setting framerate to 60 it works, so, does it mean there are errors parsing the command line parameters?

    My source is 60fps btw hence the reason I set it to 60, will try other numbers

    Edited 2 times, last by bidomo ().

  • I feel so dumb, it was the pixel format...

    But what I don't get is, why changing the pixel format for an incorrect one would say the encoder was not found?