NVENC doesn't work, just jumps from 0% to 100%.

  • It worked fine up until I had to move to a new PC yesterday, and now it just doesn't work.

    I've made sure all my drivers are up to date, ensured I installed the correct version and everything.


    Any other render that doesn't use NVENC works fine, but as soon as I try NVENC it skips from 0% to 100% and does nothing.


    I'm using Vegas 18 and an Nvidia GTX 2070 Super.


    Here is what the log file reports:


    [08:33:23] =============================================

    [08:33:23] Voukoder 6.1 (6.1.96)

    [08:33:23] by Daniel Stankewitz

    [08:33:23] ---------------------------------------------

    [08:33:23] AMD Ryzen 7 3700X 8-Core Processor

    [08:33:23] 16 logical cores

    [08:33:23] 32693 MB system memory

    [08:33:23] Display #0 on: NVIDIA GeForce RTX 2070 SUPER

    [08:33:23] ---------------------------------------------

    [08:33:23] ---------------------------------------------

    [08:33:23] Export started

    [08:33:23] ---------------------------------------------

    [08:33:23] Filename: D:\Desktop\Untitled.mp4

    [08:33:23] Application: Voukoder (VEGAS)

    [08:33:23] - Video -------------------------------------

    [08:33:23] Frame size: 1920x1080

    [08:33:23] Pixel aspect: 1:1

    [08:33:23] Timebase: 1001/30000 (29.97 fps)

    [08:33:23] Interlaced: Top first

    [08:33:23] Encoder: h264_nvenc

    [08:33:23] Options: _computeCapability=7.5 _pixelFormat=yuv420p gpu=0

    [08:33:23] Side data: <none>

    [08:33:23] Filters: <none>

    [08:33:23] Passes: 1

    [08:33:23] Color range: unknown

    [08:33:23] Color space: unknown

    [08:33:23] Color primaries: unknown

    [08:33:23] Color transfer: unknown

    [08:33:23] - Audio -------------------------------------

    [08:33:23] Timebase: 1/48000

    [08:33:23] Channels: 2

    [08:33:23] Encoder: aac

    [08:33:23] Options: _sampleFormat=fltp b=96000 profile=aac_low

    [08:33:23] Side data: <none>

    [08:33:23] Filters: filter.adelay#delays=2131S:all=1

    [08:33:23] ---------------------------------------------

    [08:33:23] Opening codec: h264_nvenc with options: gpu=0

    [08:33:23] Failed opening codec: h264_nvenc

    [08:33:23] Unable to open video encoder: h264_nvenc

    [08:33:23] Closing encoders ...

    [08:33:23] Opening encoder failed! Aborting ...

    [08:33:23] Unable to open encoder.

  • That's weird, I'm not a video editing expert but I always make sure to have any settings in regards to interlacing be disabled, and everything was working smoothly up until I switched computers yesterday..


    Did they change something overnight?


    Edit: Interlacing was on dispite Vegas telling me it was off.

  • Trying again with making sure interlacing is disabled, it makes it this far before Vegas crashes:


    [08:44:48] =============================================

    [08:44:48] Voukoder 6.1 (6.1.96)

    [08:44:48] by Daniel Stankewitz

    [08:44:48] ---------------------------------------------

    [08:44:48] AMD Ryzen 7 3700X 8-Core Processor

    [08:44:48] 16 logical cores

    [08:44:48] 32693 MB system memory

    [08:44:48] Display #0 on: NVIDIA GeForce RTX 2070 SUPER

    [08:44:48] ---------------------------------------------

    [08:44:48] ---------------------------------------------

    [08:44:48] Export started

    [08:44:48] ---------------------------------------------

    [08:44:48] Filename: D:\Desktop\Untitled.mkv

    [08:44:48] Application: Voukoder (VEGAS)

    [08:44:48] - Video -------------------------------------

    [08:44:48] Frame size: 1920x1080

    [08:44:48] Pixel aspect: 1:1

    [08:44:48] Timebase: 50000/2997003 (59.94 fps)

    [08:44:48] Interlaced: No

    [08:44:48] Encoder: h264_nvenc

    [08:44:48] Options: _computeCapability=7.5 _pixelFormat=yuv420p b=12000000 bufsize=12000000 gpu=0 profile=high rc=cbr

    [08:44:48] Side data: <none>

    [08:44:48] Filters: <none>

    [08:44:48] Passes: 1

    [08:44:48] Color range: unknown

    [08:44:48] Color space: unknown

    [08:44:48] Color primaries: unknown

    [08:44:48] Color transfer: unknown

    [08:44:48] - Audio -------------------------------------

    [08:44:48] Timebase: 1/48000

    [08:44:48] Channels: 2

    [08:44:48] Encoder: aac

    [08:44:48] Options: _sampleFormat=fltp b=192000 profile=aac_main

    [08:44:48] Side data: <none>

    [08:44:48] Filters: filter.adelay#delays=2131S:all=1

    [08:44:48] ---------------------------------------------

    [08:44:48] Opening codec: h264_nvenc with options: b=12000000|bufsize=12000000|gpu=0|profile=high|rc=cbr

    [08:44:48] Opening codec: aac with options: b=192000|profile=aac_main

  • I tried again with a clip that has no interlacing and Vegas crashes instead..


    Everything worked fine up until yesterday and installing everything onto a new computer so I'm not sure what I am missing..

  • You might startup VEGAS with having the CTRL+SHIFT keys pressed. This flushes the plugin caches.


    If it still fails please send a log with having "low level debugging" enabled. What version of VEGAS are you using?

    Help to improve this plugin and support me on patreon or paypal. Thank you.

  • Hallo Vouk, 6.1 läuft perfekt. Habe alle Codes getestet, besonders NVENC, auf Vegas Pro 13-Pro 17, finde keinen Unterschied zu 5.0

    Bemerken möchte ich noch, dass Vegas es beim Rendern nicht mag,, wenn der Dynamiche Ram zu hoch eingestellt ist.

    Mir ist Vegas dabei immer beim Rendern abgestürzt.

    Stelle vor dem Rendern den Dynamischen Ram daher immer auf 0 und das Render läuft ohne Abstutz durch.

  • Vouk

    Added the Label Not a bug
  • Vouk

    Removed the Label VEGAS Pro