Voukoder unable to initialize encoder RTX 2060 Super

  • I was using Voukoder 2.2 perfectly with a Geforce GTX 970. This weekend I upgraded that card to a RTX 2060 Super wich I heard Turing was great with NVENC. Tried to encode a Premiere project but immediately saw the error of the subject. Geforce Drivers 436.30 are installed (clean installation using DDU). I tried VBR, CBR, CQ, disabling all options and leaving it as it is in default but got the same error every time.


    Non NVENC codecs works perfectly, only the NVIDIA hardware accelerated ones fail. :(


    Below the log data


    [10:05:02] ---------------------------------------------

    [10:05:02] Export started

    [10:05:02] ---------------------------------------------

    [10:05:02] Frame size: 1920x1080

    [10:05:02] Pixel aspect: 1:1

    [10:05:02] Frame rate: 29.97

    [10:05:02] Interlaced: Top first

    [10:05:02] Color range: tv

    [10:05:02] Color space: bt709

    [10:05:02] Color primaries: bt709

    [10:05:02] Color TRC: bt709

    [10:05:02] Sample rate: 48000

    [10:05:02] Audio channels: 2

    [10:05:02] ---------------------------------------------

    [10:05:02] Opening codec: h264_nvenc with options: b=25000000|bluray-compat=1|bufsize=15000000|gpu=0|level=4.1|maxrate=30000000|preset=bd|profile=high|rc=vbr

    [10:05:02] Failed opening codec: h264_nvenc

    [10:05:02] Unable to open video encoder: h264_nvenc

    [10:05:02] Closing encoders ...

    [10:05:02] Unable to initialize the encoder.


    This has most likely to do with an invalid combination of options.


    Make sure there is at least one free NVENC session and close all other programs that make use of NVENC.


    Please check if the used options and presets comply to the selected output level. Even the encoders default configuration (no options set at all) might not comply with all levels.

  • Daniel

    Added the Label Not a bug
  • Daniel

    Removed the Label Adobe Premiere / MediaEncoder
  • Nope as I explained no options make it work, not even leaving everything as default and unchecked. For some reason RTX 2060 does not work with NVENC on Voukoder (Handbrake works perfectly tho)


    [22:18:07] ---------------------------------------------

    [22:18:07] Export started

    [22:18:07] ---------------------------------------------

    [22:18:07] Frame size: 1920x1080

    [22:18:07] Pixel aspect: 1:1

    [22:18:07] Frame rate: 29.97

    [22:18:07] Interlaced: Top first

    [22:18:07] Color range: tv

    [22:18:07] Color space: bt709

    [22:18:07] Color primaries: bt709

    [22:18:07] Color TRC: bt709

    [22:18:07] Sample rate: 48000

    [22:18:07] Audio channels: 2

    [22:18:07] ---------------------------------------------

    [22:18:07] Opening codec: h264_nvenc with options: gpu=0

    [22:18:07] Failed opening codec: h264_nvenc

    [22:18:07] Unable to open video encoder: h264_nvenc

    [22:18:07] Closing encoders ...

    [22:18:07] Unable to initialize the encoder.


    This has most likely to do with an invalid combination of options.


    Make sure there is at least one free NVENC session and close all other programs that make use of NVENC.

  • Yes I did a clean installation of the latest drivers 436.30. Used DDU (display driver unninstaller) to clean old drivers, then installed 436.30 using the clean installation option.


    I did check for free NVENC session and there wasno problem there, will try againg later and grab an screenshot to post here

  • Ok here are the screencaps of the settings used and the encoder sessions. It never opens a session and there is no other program with an open session itself.


    Again I tested Handbrake and that works ok.


    Below the log of this new test, attached all the screencaps


    [07:37:58] ---------------------------------------------

    [07:37:58] Export started

    [07:37:58] ---------------------------------------------

    [07:37:58] Frame size: 1920x1080

    [07:37:58] Pixel aspect: 1:1

    [07:37:58] Frame rate: 29.97

    [07:37:58] Interlaced: Top first

    [07:37:58] Color range: tv

    [07:37:58] Color space: bt709

    [07:37:58] Color primaries: bt709

    [07:37:58] Color TRC: bt709

    [07:37:58] Sample rate: 48000

    [07:37:58] Audio channels: 2

    [07:37:58] ---------------------------------------------

    [07:37:58] Opening codec: h264_nvenc with options: gpu=0

    [07:37:58] Failed opening codec: h264_nvenc

    [07:37:58] Unable to open video encoder: h264_nvenc

    [07:37:58] Closing encoders ...

    [07:37:58] Unable to initialize the encoder.


    This has most likely to do with an invalid combination of options.


    Make sure there is at least one free NVENC session and close all other programs that make use of NVENC.


    Voukoder.jpgVoukoder Sessions.jpgSessions Handbrake.jpg

  • I'm having the same issue with a GTX1060. (2.2 and 2.2.2 - NVENC h264)

    NVENC HEVC seems to work though. Do you only have the prob with h.264?

    Actually I didn´t try HVEC, after I saw your post I tried it but nope, it doesnt work


    Make sure there is at least one free NVENC session and close all other programs that make use of NVENC.

    [12:51:43] ---------------------------------------------

    [12:51:43] Export started

    [12:51:43] ---------------------------------------------

    [12:51:43] Frame size: 1920x1080

    [12:51:43] Pixel aspect: 1:1

    [12:51:43] Frame rate: 29.97

    [12:51:43] Interlaced: Top first

    [12:51:43] Color range: tv

    [12:51:43] Color space: bt709

    [12:51:43] Color primaries: bt709

    [12:51:43] Color TRC: bt709

    [12:51:43] Sample rate: 48000

    [12:51:43] Audio channels: 2

    [12:51:43] ---------------------------------------------

    [12:51:43] Opening codec: hevc_nvenc with options: gpu=0

    [12:51:44] Failed opening codec: hevc_nvenc

    [12:51:44] Unable to open video encoder: hevc_nvenc

    [12:51:44] Closing encoders ...

    [12:51:44] Unable to initialize the encoder.


    This has most likely to do with an invalid combination of options.


    Make sure there is at least one free NVENC session and close all other programs that make use of NVENC.

  • The only thing that is not set to default is that your source and export is interlaced. Maybe you could try export a non interlaced source file just to be sure it's not the interlacing.

    EUREKA!!!! Encoding a progressive sequence did work!


    Now I wonder why would be that? I could encode those interlaced projects with the GTX 970 before, just finished such a project one month ago :/


    [21:46:45] ---------------------------------------------

    [21:46:45] Export started

    [21:46:45] ---------------------------------------------

    [21:46:45] Frame size: 1920x1080

    [21:46:45] Pixel aspect: 1:1

    [21:46:45] Frame rate: 29.97

    [21:46:45] Interlaced: No

    [21:46:45] Color range: tv

    [21:46:45] Color space: bt709

    [21:46:45] Color primaries: bt709

    [21:46:45] Color TRC: bt709

    [21:46:45] Sample rate: 48000

    [21:46:45] Audio channels: 2

    [21:46:45] ---------------------------------------------

    [21:46:45] Opening codec: h264_nvenc with options: gpu=0

    [21:46:45] Opening codec: aac with options: b=192000|profile=aac_low

    [21:46:45] Requesting pixel format: yuv420p

    [21:46:45] Frame #0: vRender: 141362 us, vProcess: 10 us, vEncoding: 5680 us, Latency: 147107 us

    [21:46:45] Frame #1: vRender: 26 us, vProcess: 6 us, vEncoding: 1587 us, aRender: 27 us, aEncoding: 2819 us, Latency: 5044 us

    [21:46:45] Frame #2: vRender: 27 us, vProcess: 5 us, vEncoding: 1862 us, aRender: 55 us, aEncoding: 238 us, Latency: 3333 us

    [21:46:45] Frame #3: vRender: 22 us, vProcess: 5 us, vEncoding: 1872 us, aRender: 82 us, aEncoding: 300 us, Latency: 2333 us

    [21:46:45] Frame #4: vRender: 26 us, vProcess: 6 us, vEncoding: 1702 us, aRender: 20 us, aEncoding: 278 us, Latency: 2464 us

    [21:46:45] Frame #5: vRender: 305 us, vProcess: 4 us, vEncoding: 1672 us, aRender: 73 us, aEncoding: 301 us, Latency: 2401 us

    [21:46:45] Frame #6: vRender: 28 us, vProcess: 6 us, vEncoding: 1688 us, aRender: 22 us, aEncoding: 282 us, Latency: 2465 us

    [21:46:45] Frame #7: vRender: 29 us, vProcess: 6 us, vEncoding: 1703 us, aRender: 89 us, aEncoding: 310 us, Latency: 2187 us

    [21:46:45] Frame #8: vRender: 29 us, vProcess: 7 us, vEncoding: 2042 us, aRender: 22 us, aEncoding: 282 us, Latency: 2837 us

    [21:46:45] Frame #9: vRender: 78859 us, vProcess: 8 us, vEncoding: 2314 us, aRender: 22 us, aEncoding: 222 us, Latency: 81875 us

    [21:46:45] Frame #10: vRender: 204 us, vProcess: 6 us, vEncoding: 2153 us, aRender: 98 us, aEncoding: 338 us, Latency: 2851 us

    [21:46:45] Frame #11: vRender: 522 us, vProcess: 7 us, vEncoding: 2391 us, aRender: 22 us, aEncoding: 297 us, Latency: 3699 us

    [21:46:45] Frame #12: vRender: 22 us, vProcess: 7 us, vEncoding: 2246 us, aRender: 75 us, aEncoding: 323 us, Latency: 2725 us

    [21:46:45] Frame #13: vRender: 22 us, vProcess: 5 us, vEncoding: 2181 us, aRender: 19 us, aEncoding: 229 us, Latency: 2867 us

    [21:46:45] Frame #14: vRender: 20 us, vProcess: 5 us, vEncoding: 2076 us, aRender: 93 us, aEncoding: 278 us, Latency: 2526 us

    [21:46:45] Frame #15: vRender: 39948 us, vProcess: 10 us, vEncoding: 2340 us, aRender: 22 us, aEncoding: 298 us, Latency: 43101 us

    [21:46:45] Frame #16: vRender: 23 us, vProcess: 6 us, vEncoding: 2054 us, aRender: 22 us, aEncoding: 268 us, Latency: 2846 us

    [21:46:45] Frame #17: vRender: 21 us, vProcess: 5 us, vEncoding: 2267 us, aRender: 81 us, aEncoding: 330 us, Latency: 2763 us

    [21:46:45] Frame #18: vRender: 33 us, vProcess: 7 us, vEncoding: 1520 us, aRender: 21 us, aEncoding: 195 us, Latency: 2099 us

    [21:46:45] Frame #19: vRender: 22 us, vProcess: 5 us, vEncoding: 1375 us, aRender: 65 us, aEncoding: 225 us, Latency: 1735 us

    [21:46:45] Frame #20: vRender: 227 us, vProcess: 5 us, vEncoding: 2042 us, aRender: 17 us, aEncoding: 193 us, Latency: 2828 us

    [21:46:45] Frame #21: vRender: 18 us, vProcess: 4 us, vEncoding: 2091 us, aRender: 88 us, aEncoding: 257 us, Latency: 2498 us

    [21:46:45] Frame #22: vRender: 25 us, vProcess: 5 us, vEncoding: 1519 us, aRender: 17 us, aEncoding: 220 us, Latency: 2141 us

    [21:46:45] Frame #23: vRender: 24 us, vProcess: 5 us, vEncoding: 2119 us, aRender: 60 us, aEncoding: 242 us, Latency: 2490 us

    ...

    ...

    ...

  • Found an interesting link...


    https://devtalk.nvidia.com/def…erlaced-video-with-nvenc/


    Proceeded to check myself the available features of the RTX 2060 for NVENC and it seems like nVidia dropped interlaced encoding support on RTX cards :rolleyes:


    RTX 2060 NVEnc features.jpg

  • Hi Guys,

    Looks like i have now a simmilar problem.

    Using version 4.1 in Premiere on my RTX 2080 Super

    Just made a normal project with adowbe premiere ant tried to convert with nvenc hevc
    But it aborts.


    Please can u help me and what that interlaced encoding means?


    Es sind DV Avi Quellen die ich von Konvertierten V8 Video Bändern bearbeite.


    How can i get it to work?



    Here is my log file and also a picture from media ino with the details of the media file i need to convert.



    Thanks

    and i aprecciate your work!


    Cheers Matt

  • Interlacing


    Solution:

    1. You could deinterlace (convert it to non-interlaced) it first. Either by premiere oder using a voukoder filter..
    2. You could use the x265 encoder instead
    3. Buy a second cheap older GPU and use it for encoding
  • Thanks Vouk for the quick answer. :)


    How does it work with Premiere or with the voukoder filter? (Workflow, how to set it)


    Will i losse any quality through that?


    Sorry for asking, im not yet that experienced with video encoding.


    I appreciate your time and work a lot.


    Cheers Matt