The 2.1.1 version does not seem to be compatible with AMD's rx 5700xt.

  • I am working on i9 9900K, Radeon ™ RX 5700XT D6 8GB / VGA. However, the speed of the Voukoder did not occur at all, but rather slowed down. In my opinion, it is not yet compatible with the RX 5700XT graphics card.

    <-- Voukoder (time : 03:38)<--Hx264 (time : 03:07)

  • Oh i've already read that page. So i wanted to request updating to fix this issue and check compatibility at next the version.??

  • I don't know it is sure


    Log file created: 2019-07-22 오후 9:51:45

    -------------------------------------------

    Ticks = 985 <7064> <Wasapi initialization> <5> Time = 0.0399362second

    Ticks = 1250 <19220> <AnywhereLocalClient> <5> Local Hub HTTP port retrieved, port: 60101

    Ticks = 1360 <7064> <EncoderNVH264> <5> New instance.

    Ticks = 1360 <7064> <EncoderNVH264> <5> Constructor.

    Ticks = 1360 <7064> <EncoderNVH264> <5> Start service.

    Ticks = 1360 <7064> <EncoderNVH264> <5> Load NVENC API.

    Ticks = 1360 <7064> <EncoderNVH264> <5> FAILED to load NVENC API.

    Ticks = 1594 <7064> <DS> <5> GPUSniffer launching with test mask 254

    Ticks = 4828 <7064> <EACL.HostedLogin> <5> Entitlement record did not pass application entitlement policy, ccAdobeID: "my mail ID", ccPersonGUID: "AdobeID"

    Ticks = 4828 <7064> <EACL.HostedLogin> <4> Non-entitled response received, ccAdobeID: "my mail ID", ccPersonGUID: "AdobeID", error_code: "403010"

    Ticks = 5000 <7064> <AMEApp> <0> Time taken to load MediaCore plugins: 1512.34 milliseconds.

    Ticks = 8297 <19220> <LoadProject> <0> 0.0778728s

    Ticks = 8750 <19220> <MSDKDecoderWithMCDemux> <5> No Intel device D3D11 or DX9 context created, hardware decode not available.

    Ticks = 8875 <7064> <AMEApp> <1> Entering RunEventLoop

    Ticks = 44516 <9812> <PostProcessBaseUploader> <5> Page ID

    Ticks = 44532 <9812> <PostProcessBaseUploader> <5> Page ID

    Ticks = 44578 <5976> <PrSDKSequenceAudioSuite> <5> Deprecated function. Use MakeAudioRenderer() passing channel layout instead.

    Ticks = 239969 <5976> <ExporterHost::BeginThreadExport> <5> Exporter finished in : 195.432 seconds. Result code: 0 Destination:C:\Users\tmdal\OneDrive\諛뷀깢 ?붾㈃\Voukoder_Test.mp4

    Edited once, last by LEESM ().

  • It is version 1.1.1 log file


    Log file created: 2019-07-22 오후 9:51:45

    -------------------------------------------

    Ticks = 985 <7064> <Wasapi initialization> <5> Time = 0.0399362second

    Ticks = 1250 <19220> <AnywhereLocalClient> <5> Local Hub HTTP port retrieved, port: 60101

    Ticks = 1360 <7064> <EncoderNVH264> <5> New instance.

    Ticks = 1360 <7064> <EncoderNVH264> <5> Constructor.

    Ticks = 1360 <7064> <EncoderNVH264> <5> Start service.

    Ticks = 1360 <7064> <EncoderNVH264> <5> Load NVENC API.

    Ticks = 1360 <7064> <EncoderNVH264> <5> FAILED to load NVENC API.

    Ticks = 1594 <7064> <DS> <5> GPUSniffer launching with test mask 254

    Ticks = 4828 <7064> <EACL.HostedLogin> <5> Entitlement record did not pass application entitlement policy, ccAdobeID: "my mail ID", ccPersonGUID: "AdobeID"

    Ticks = 4828 <7064> <EACL.HostedLogin> <4> Non-entitled response received, ccAdobeID: "my mail ID", ccPersonGUID: "@AdobeID", error_code: "403010"

    Ticks = 5000 <7064> <AMEApp> <0> Time taken to load MediaCore plugins: 1512.34 milliseconds.

    Ticks = 8297 <19220> <LoadProject> <0> 0.0778728s

    Ticks = 8750 <19220> <MSDKDecoderWithMCDemux> <5> No Intel device D3D11 or DX9 context created, hardware decode not available.

    Ticks = 8875 <7064> <AMEApp> <1> Entering RunEventLoop

    Ticks = 44516 <9812> <PostProcessBaseUploader> <5> Page ID

    Ticks = 44532 <9812> <PostProcessBaseUploader> <5> Page ID

    Ticks = 44578 <5976> <PrSDKSequenceAudioSuite> <5> Deprecated function. Use MakeAudioRenderer() passing channel layout instead.

    Ticks = 239969 <5976> <ExporterHost::BeginThreadExport> <5> Exporter finished in : 195.432 seconds. Result code: 0 Destination:C:\Users\tmdal\OneDrive\諛뷀깢 ?붾㈃\Voukoder_Test.mp4

    Ticks = 309907 <7064> <PostProcessBaseUploader> <5> Page ID

    Ticks = 309907 <7064> <PostProcessBaseUploader> <5> Page ID

    Ticks = 309922 <7064> <PostProcessBaseUploader> <5> Page ID

    Ticks = 309922 <7064> <PostProcessBaseUploader> <5> Page ID

    Ticks = 310110 <7532> <MSDKDecoderWithMCDemux> <5> No Intel device D3D11 or DX9 context created, hardware decode not available.

    Ticks = 355141 <7532> <MSDKDecoderWithMCDemux> <5> No Intel device D3D11 or DX9 context created, hardware decode not available.

    Ticks = 600469 <7064> <PostProcessBaseUploader> <5> Page ID

    Ticks = 600469 <7064> <PostProcessBaseUploader> <5> Page ID

    Ticks = 600532 <7064> <PostProcessBaseUploader> <5> Page ID

    Ticks = 600547 <7064> <PostProcessBaseUploader> <5> Page ID

    Ticks = 600782 <10796> <MSDKDecoderWithMCDemux> <5> No Intel device D3D11 or DX9 context created, hardware decode not available.

    Ticks = 668219 <14764> <PostProcessBaseUploader> <5> Page ID

    Ticks = 668235 <14764> <PostProcessBaseUploader> <5> Page ID

    Ticks = 668235 <8660> <PrSDKSequenceAudioSuite> <5> Deprecated function. Use MakeAudioRenderer() passing channel layout instead.

    Ticks = 668313 <10796> <MSDKDecoderWithMCDemux> <5> No Intel device D3D11 or DX9 context created, hardware decode not available.

    Ticks = 869938 <8660> <ExporterHost::BeginThreadExport> <5> Exporter finished in : 201.712 seconds. Result code: 0 Destination:C:\Users\tmdal\OneDrive\諛뷀깢 ?붾㈃\Voukoder_Test_1.mp4

  • And it is H.264

    Log file created: 2019-07-22 오후 9:51:45

    -------------------------------------------

    Ticks = 985 <7064> <Wasapi initialization> <5> Time = 0.0399362second

    Ticks = 1250 <19220> <AnywhereLocalClient> <5> Local Hub HTTP port retrieved, port: 60101

    Ticks = 1360 <7064> <EncoderNVH264> <5> New instance.

    Ticks = 1360 <7064> <EncoderNVH264> <5> Constructor.

    Ticks = 1360 <7064> <EncoderNVH264> <5> Start service.

    Ticks = 1360 <7064> <EncoderNVH264> <5> Load NVENC API.

    Ticks = 1360 <7064> <EncoderNVH264> <5> FAILED to load NVENC API.

    Ticks = 1594 <7064> <DS> <5> GPUSniffer launching with test mask 254

    Ticks = 4828 <7064> <EACL.HostedLogin> <5> Entitlement record did not pass application entitlement policy, ccAdobeID: "my mail ID", ccPersonGUID: "@AdobeID"

    Ticks = 4828 <7064> <EACL.HostedLogin> <4> Non-entitled response received, ccAdobeID: "my mail ID", ccPersonGUID: "@AdobeID", error_code: "403010"

    Ticks = 5000 <7064> <AMEApp> <0> Time taken to load MediaCore plugins: 1512.34 milliseconds.

    Ticks = 8297 <19220> <LoadProject> <0> 0.0778728s

    Ticks = 8750 <19220> <MSDKDecoderWithMCDemux> <5> No Intel device D3D11 or DX9 context created, hardware decode not available.

    Ticks = 8875 <7064> <AMEApp> <1> Entering RunEventLoop

    Ticks = 44516 <9812> <PostProcessBaseUploader> <5> Page ID

    Ticks = 44532 <9812> <PostProcessBaseUploader> <5> Page ID

    Ticks = 44578 <5976> <PrSDKSequenceAudioSuite> <5> Deprecated function. Use MakeAudioRenderer() passing channel layout instead.

    Ticks = 239969 <5976> <ExporterHost::BeginThreadExport> <5> Exporter finished in : 195.432 seconds. Result code: 0 Destination:C:\Users\tmdal\OneDrive\諛뷀깢 ?붾㈃\Voukoder_Test.mp4

    Ticks = 309907 <7064> <PostProcessBaseUploader> <5> Page ID

    Ticks = 309907 <7064> <PostProcessBaseUploader> <5> Page ID

    Ticks = 309922 <7064> <PostProcessBaseUploader> <5> Page ID

    Ticks = 309922 <7064> <PostProcessBaseUploader> <5> Page ID

    Ticks = 310110 <7532> <MSDKDecoderWithMCDemux> <5> No Intel device D3D11 or DX9 context created, hardware decode not available.

    Ticks = 355141 <7532> <MSDKDecoderWithMCDemux> <5> No Intel device D3D11 or DX9 context created, hardware decode not available.

    Ticks = 600469 <7064> <PostProcessBaseUploader> <5> Page ID

    Ticks = 600469 <7064> <PostProcessBaseUploader> <5> Page ID

    Ticks = 600532 <7064> <PostProcessBaseUploader> <5> Page ID

    Ticks = 600547 <7064> <PostProcessBaseUploader> <5> Page ID

    Ticks = 600782 <10796> <MSDKDecoderWithMCDemux> <5> No Intel device D3D11 or DX9 context created, hardware decode not available.

    Ticks = 668219 <14764> <PostProcessBaseUploader> <5> Page ID

    Ticks = 668235 <14764> <PostProcessBaseUploader> <5> Page ID

    Ticks = 668235 <8660> <PrSDKSequenceAudioSuite> <5> Deprecated function. Use MakeAudioRenderer() passing channel layout instead.

    Ticks = 668313 <10796> <MSDKDecoderWithMCDemux> <5> No Intel device D3D11 or DX9 context created, hardware decode not available.

    Ticks = 869938 <8660> <ExporterHost::BeginThreadExport> <5> Exporter finished in : 201.712 seconds. Result code: 0 Destination:C:\Users\tmdal\OneDrive\諛뷀깢 ?붾㈃\Voukoder_Test_1.mp4

    Ticks = 1103469 <7064> <PostProcessBaseUploader> <5> Page ID

    Ticks = 1103469 <7064> <PostProcessBaseUploader> <5> Page ID

    Ticks = 1103532 <7064> <PostProcessBaseUploader> <5> Page ID

    Ticks = 1103547 <7064> <PostProcessBaseUploader> <5> Page ID

    Ticks = 1103782 <17716> <MSDKDecoderWithMCDemux> <5> No Intel device D3D11 or DX9 context created, hardware decode not available.

    Ticks = 1191438 <7064> <PostProcessBaseUploader> <5> Page ID

    Ticks = 1191453 <7064> <PostProcessBaseUploader> <5> Page ID

    Ticks = 1191453 <11624> <MSDKDecoderWithMCDemux> <5> No Intel device D3D11 or DX9 context created, hardware decode not available.

    Ticks = 1194719 <7064> <PostProcessBaseUploader> <5> Page ID

    Ticks = 1194735 <7064> <PostProcessBaseUploader> <5> Page ID

    Ticks = 1219797 <11624> <PostProcessBaseUploader> <5> Page ID

    Ticks = 1219797 <11624> <PostProcessBaseUploader> <5> Page ID

    Ticks = 1219891 <17716> <MSDKDecoderWithMCDemux> <5> No Intel device D3D11 or DX9 context created, hardware decode not available.

    Ticks = 1397313 <2220> <MSDKDecoderWithMCDemux> <5> No Intel device D3D11 or DX9 context created, hardware decode not available.

    Ticks = 1405766 <2220> <EncoderStateH264> <1> Time taken for; video =165946 audio=7342 mux=15

    Ticks = 1405766 <2220> <ExporterHost::BeginThreadExport> <5> Exporter finished in : 185.973 seconds. Result code: 0 Destination:C:\Users\tmdal\OneDrive\諛뷀깢 ?붾㈃\Voukoder_Test_2.mp4

    • Official Post

    Okay, render times look pretty good. It is actually the video encoder that is slow.


    Unfortuantely I don't have much experience with AMD encoders. I just have a cheap AMD GPU for developing and no contact person at AMD.


    How many FPS do you get when you do the same encoding with FFmpeg on the command line?

  • How can i check FPS when i do the encoding with FFmpeg on the command line?

    and what is the command line?

    Edited once, last by LEESM ().

  • Vouk

    Added the Label In Progress
  • umm... i don't know it is surely faster. almost same! but I found something new. When I changed from AAC (FFmpeg) to mp3, the encoding speed was reduced by about 7 minutes. This is about 20 percent time saving. Is this a natural thing?

    • Official Post

    Yes, it should be slightly faster because premiere is not involved rendering the frame. But if it is almost the same then it is okay.


    About aac vs. mp3... did you try to export video only? What about that?

  • Vouk

    Set the Label from In Progress to Not a bug
  • Vouk

    Added the Label Adobe Premiere / MediaEncoder