Posts by Drago3110

    I know i am late... but it works!!!! GOPs per IDR value 1 is the solution!!!!

    Thank you!!!


    And for the Germans under us :D:


    Ich weiß ich bin spät dran aber... ES FUNKTIONIERT!!!! "GOPs per IDR" auf 1 setzen und ich kann problemlos spulen!!!!

    Quote

    Checking the GOPs per IDR option and setting its value to 1 can solve the problem of fast forward freeze. I think Voukoder can set this value to 1 by default when the user uses the HEVC AMF encoder.

    Ahhh thank you... good to know. I will try it.

    und welche Unterschiede zeigt MediaInfo zwischen Magix- u Voukoder-Encodings?

    Ich habe übrigens das Ganze mit dem H.265 über die CPU probiert. Auch über Voukoder. Dort gibt es auch keine Probleme und ich kann normal im Video springen. Den log poste ich mal statt dem des Magix Videos.



    Hier einmal der log des Voukoder-Videos per AMD AMF:


    Dann hier der log für das Video welches mit H.265 über die CPU gerendert wurde:

    Hi,


    the important things at first in english. Maybe there are more people with this problem:


    My PC:


    - Win 10 Pro 64 Bit + aktuellste Updates

    - AMD Ryzen 2700

    - AMD RX 580

    - 16 GB DDR4 3000 RAM

    - Asus Board mit Chipsatz B450


    I use voukoder and vegas pro to render my videos. There are no problems during the rendering. But when i use HEVC H.265 via AMD AMF then there is a problem. When i watch the video via VLC player or Media Player Classiv or Windows Media Player an i want to jump to a specific time then the video stop completely and vlc player is not reacting. After 30 to 60 seconds the video play normal at the time where i jumped.


    The problem is just via AMD AMF H.265 rendering. H.265 via cpu works normal.

    _____________________________________________________________________________________________________________

    Hallo,


    erstmal vllt. etwas zum System:


    - Win 10 Pro 64 Bit + aktuellste Updates

    - AMD Ryzen 2700

    - AMD RX 580

    - 16 GB DDR4 3000 RAM

    - Asus Board mit Chipsatz B450


    Es gab vor einiger Zeit ja das Problem, dass wenn ich über Magix + Voukoder gerendert habe, es sporadisch zu Tonaussetzern kam.

    Nachdem das Plugin aktualisiert wurde konnte ich die Videos auch alle problemlos abspielen.


    Nun ist mir aber folgendes aufgefallen:

    Ich rendere seit kurzer Zeit Videos (60fps) über "HEVC (AMD AMF) H.265" und skaliere diese auch gleich mit dem zscale auf 1440p 60fps. Funktioniert auch alles wunderbar. GPU wird voll ausgelastet und Video lässt sich auch abspielen. Ich benutze den VLC-Player. Wenn ich jetzt aber in dem Video spulen möchte, bzw. springen möchte, also z. B. auf der Wiedergabeleiste irgendwo hinklicke, dann springt die Wiedergabeleiste auch dahin, allerdings stoppt das Video komplett und es passiert erst einmal eine Minute (habe die Zeit gestoppt) gar nichts. Ich kann den VLC-Player dann auch nicht schließen, bzw. schließt sich das Fenster, aber der Prozess bleibt so lange im Taskmanager offen wie er zum "springen" im Video braucht. Ich kann dann auch kein anderes "normales" Video starten.


    Mir ist aufgefallen dass im Taskmanager bei der Grafikkarte der Punkt "Video Decode" in der Zeit in der das Video hängt auf 100 % läuft (s. Anhang).

    Unbenannt.png


    Z. B. das Video im Bild geht ca. 19 Minuten. Vom Anfang zur Mitte zu springen hat 1 Minute gedauert (Zeit habe ich gestoppt). Das Springen vom Anfang bis Sekunde 29 hat indes nur 8 Sekunden gedauert.


    Ich dachte erst das liegt evtl. am VLC-Player, aber weder mit dem Windows Media Player, noch mit dem Media Player Classic funktioniert das springen. Dann habe ich das Video mit dem Magix internen HEVC H.265 über meine Grafikkarte rendern lassen. Und dort funktioniert es wie gewohnt. Ich klicke ins Video und sofort läuft das Video an der Stelle weiter.


    Jetzt natürlich meine Frage. Hat noch jemand dieses Problem?


    Edit: Bei Videos die mit x264 ( über CPU und Grafikkarte) gerendert werden funktioniert es ohne Probleme.

    Ich habe leider nur eine alte r9 380x. Die unterstützt nur kein 265 🙄. Die hätte ich sonst dir überlassen.


    Ich halte mal nach einer günstigen gebrauchten auf ebay Kleinanzeige oder so ausschau.

    Das mindeste wäre ja eine rx460 wenn ich mich recht erinnere. Mit der könntest du dann schon etwas anfangen?


    MfG

    Hi, :)


    also ich habe den Voukoder nun auch mal installiert.


    Vorneweg meine Hardware:


    AMD Ryzen 2700

    AMD RX 580 - 8 GByte RAM (aktuellster Treiber)

    16 GB DDR 4 RAM


    Ich nehme mit dem MSI Afterburner Videos mit dem Lagarith lossless Codec auf. 2 Soundpuren inklusive.

    Meine Webcam nehme ich normal mit OBS auf.


    Ich habe mein Video in Premiere entsprechend zurechgeschnippselt und wollte nun mal deinen Koder probieren :)


    Installiert ist er und er wird auch angezeigt Bild. Dann auf AMD AMF HEVC gestellt.


    Ich habe dann noch CQP auf 22 gestellt und wollte dann loslegen.


    Allerdings passiert jetzt folgendes. Das Video ist ca. 15 Minuten lang und liegt in 1080p vor, es soll auch nichts resized werden, sondern einfach nur gerendet. Wenn ich das Rendern starte, habe ich das Gefühl er nutzt die Grafikkarte nicht. Er berechnet mir eine horrende Restzeit, aktuell über eine Stunde (Bild). Und wie im Taskmanager zu sehen ist scheint weder die CPU noch die Grafikkarte großartig etwas zu machen. Allerdings weiß ich natürlich nicht ob man so auf die berechnete Zeit vertrauen kann...


    Ich habe das davor immer per FrameServer + MeGui und Vegas Pro + x264 codec gemacht. Dort brauchte ich ca. 30 - 40 Minuten für ein Video dieser Art (CPU render). Ich hab mal testweise deinen x264 genutzt (CPU render), dort wird mir dann auch eine Restzeit von ca. 40 Minuten angezeigt. Also scheint das GPU rendering da genauso schnell zu sein wie das CPU rendering.... Hmmm


    Vielleicht hast du ja einen Rat? Solltest du irgendetwas brauchen, sag nur Bescheid. :)


    Vielen Dank schon mal.