Rendered videos using x264 (ffmpeg v4.1 or higher) - Bug in windows media player of the Windows 7

  • Hi,


    I noticed that videos rendered with x264 (ffmpeg version 4.1 or higher) do not display correctly in windows media player on windows 7. In the other players (classic media player, vlc, quick time player) the videos display correctly.


    Here, videos rendered in version 1.1.3 of Voukoder are displayed correctly in windows media player of Windows 7 as this version of Voukoder must use version 4.0 or earlier of the ffmpeg. The videos rendered in version 2.2.0 of Voukoder are not displayed correctly in windows media player of Windows 7, because this version of Voukoder must use version 4.1 or higher.


    To resolve this ffmpeg bug, I replace the ffmpeg file with version 4.0 in all applications that use ffmpeg. The ffmpeg version 4.0 was the last version that does not have this bug.


    Is there any way to do this in Voukoder 2.2.0? I just want to replace the version of fffmpeg with version 4.0 so that rendered videos can display correctly in windows media player of windows 7.


    I made a screen recording showing this case. It can be downloaded at this link:

    https://www.dropbox.com/s/dzx8…ia%20player-Win7.rar?dl=0


    Thank you so much for developing this work. I look forward to seeing the Magix Vegas version of Voukoder.

  • Joelson

    Changed the title of the thread from “FFmpeg bug after version 4.0 in windows media player of the Windos 7” to “Rendered videos using x264 (ffmpeg v4.1 or higher) - Bug in windows media player of the Windows 7”.
  • Unfortunately this is not possible. FFmepg / libav gets statically linked into voukoder, so there is no ffmpeg.dll to replace. I am also not sure if the interface are compatible.

    Stay up-to-date and follow me on Twitter. Tell me your feedback.


    Help to improve this plugin and support me on patreon. Thank you.