Application 11.3 crash DaVinci Resolve Studio 18+

  • Hello


    It's just me, or other people experienced an immediate crash of Resolve Studio 18+ as soon as rendering start using HEVC NVENC with 11.3 app ? (10bits encoding, Nvidia 3060 GPU, last Nvidia studio driver updated)

    Reverting back to 11.1 works perfectly well again.


    I had no time yet to make more tests because I need to deliver my project, but i quickly tried on already existing projects with already existing Voukoder job on render queue : crash with 11.3, ok with 11.1 and also with a brand new project, same crash with 11.3. Not tried with 8 bit yet, only 10bits HEVC.


    Thanks

    Edited 4 times, last by erick06 ().

  • erick06

    Changed the title of the thread from “Application 11.3 crash DaVinci Resole Studio 18+” to “Application 11.3 crash DaVinci Resolve Studio 18+”.
  • Vouk

    Approved the thread.
  • Thanks for your answer.


    I confim the crash as soon as i start a render with application 11.3.


    I made for that test a brand new project with 2 seconds of blank (black) UHD video.


    You will find as attachement !

    - a file with all versions summary on my system (windows, Nvidia, resolve, voukoder)

    - a voukoder full log file for a sucessfull rendering with application 11.1

    - a voukoder full log file for crashed rendering with application 11.3


    As you can see on the log, the hevc_nvenc encoder cannot be opened by app 11.3.


    Thank you for your help, no emergency as 11.1 still working perfectly for now, and I revert to that version.


    system-versions.txttest-vouk-11.1-log.txttest-vouk-11.3-log.txt

    • Official Post

    There was a change when moving from NVENC SDK 9 to 11.1. The value of presets do not match anymore. NVIDIA is now using the presets p1-p7 instead of "bd", "hq" and so on. Once you update that preset everything should be working again.


    This might help you with finding the right replacement value: https://docs.nvidia.com/video-…c-preset-migration-guide/

  • Thanks, but same crash problem with "px" profiles :


    Options in GUI :


    2pass=0 b=12000000 bufsize=15000000 cq=0 gpu=0 maxrate=12000000 preset=p5 profile=main10 rc=vbr_hq rc-lookahead=16 tier=high


    (i removed the render queue and created a new one to be sure that no "old" presets stay active)


    Looks like the problem is linked to ffmpeg 2pass=0 argument


    [11:06:02] FFmpeg: InitializeEncoder failed: invalid param (8): Preset P1 to P7 not supported with older 2 Pass RC Modes(CBR_HQ, VBR_HQ) and cbr lowdelayEnable NV_ENC_RC_PARAMS::multiPass flag for two pass encoding and set

    [11:06:02] FFmpeg: Calling dl_fn->cuda_dl->cuCtxPushCurrent(ctx->cu_context)

    [11:06:02] FFmpeg: Calling dl_fn->cuda_dl->cuCtxPopCurrent(&dummy)

    [11:06:02] FFmpeg: Calling dl_fn->cuda_dl->cuCtxDestroy(ctx->cu_context_internal)

    [11:06:02] FFmpeg: Nvenc unloaded


    But this argument is automatically added by voukoder and i cannot remove it in GUI

  • Nope :(

    Defined a new job :

    b=60000000 bufsize=15000000 cq=0 gpu=0 maxrate=120000000 multipass=0 preset=p5 profile=main10 rc=vbr_hq rc-lookahead=16 tier=high


    Exactly the the same 2pass params ffmeg failed :


    [11:34:17] FFmpeg: InitializeEncoder failed: invalid param (8): Preset P1 to P7 not supported with older 2 Pass RC Modes(CBR_HQ, VBR_HQ) and cbr lowdelayEnable NV_ENC_RC_PARAMS::multiPass flag for two pass encoding and set


    Maybe as far as multipass is not (yet) supported with resolve, the easyest solution should be to totaly remove it from params


    voukoder.org/attachment/1642/

  • Hello


    Thanks for your help

    it's OK now in 11.3.2 with a new task in the render queue generated with the new GUI options ;


    b=60000000 bufsize=15000000 cq=0 gpu=0 maxrate=120000000 multipass=0 preset=p6 profile=main10 rc=vbr rc-lookahead=16 tier=high


    The main draw back actually, is that each previous resolve project already using voukoder in version < 11.3, where render tasks are stored in the project, including voukoder parameters, are no more usable "as is" starting with 11.3 and will produce a resolve crash with no information.


    Maybe a warning popup when old SDK options are reloaded from an old project, asking to remove and recreate all voukoder tasks should be very usefull to avoid users opening again and again this "bug" like i do.


    At least a warning about the requirement to recreate resolve stored render tasks on the website should be usefull for many users.


    Again thanks for your help for this issue

  • Vouk

    Added the Label Fixed
  • Vouk

    Removed the Label DaVinci Resolve