Posts by spreeni

    I did some more tests and I found out, that the param B-Pyramid is the cause of the missing first and second frame. If I set it to "disable", sequences are encoded completely. If it is set to "strict" or "normal" (or left unchecked as default) the first two frames are cut off.

    So now I know, why - and it is probably no plug-in bug. Btw, what is the recommended setting for B-Pyramid? Normal, strict or better disabled?

    I did some tests with a sequence of white noise. I made a screenshot of the spectralview in Audition. The results are attached as PNG-pictures:


    01-uncompreessed.png: Uncompressed - this is what it shoul look like

    02-AAC-ffmpg_CBR_320.png: The native FFMPG AAC Encoder at 320kbit (48Khz stereo) - look at these "glitches"


    03-AAC-ffmpg_CBR_384.png: Same settings but slightly higher bitrate (384kbit) - noticeably better quality


    04-fdkAAC_CBR_320.png: fdk AAC Encoder at 320kbit, very good quality, but frequencies above 17Khz are cut


    05-AAC_x264Pro-plug-in: AAC Encoder of the x264Pro plug-in. I don't know what encoder is used here but it looks outstanding

    So my result is: For best AAC quality in voukoder use the native FFMPG AAC encoder at higher bitrates (min 384) or use the the fdk encoder and live without the 17.000+ frequencies. After some rock concerts these frequencies are blows away, anyway ;) )

    Thank you for response, I tried to find some more informations about it in the ffmpg wiki, but unfortunately it makes it not quite clear:


    The Fraunhofer FDK AAC codec library. This is currently the highest-quality AAC encoder available with ffmpeg.

    and then, later


    For AAC-LC: as of 2017 this is no longer necessarily the case. The built in aac encoder is quite good.

    Fo me it sounds like the built in acc encoder makes no difference in AAC-LC, but it still does in main profile. However, I think I have to do some tests of my own, and yes, you're right, lossless is the best but ...not so efficient.