Posts by AyoKeito

    Hello. Is it possible to add "Match source" checkboxes and\or button to Voukoder? It can be hard to adjust all settings, especially when re-encoding in AME and have different framerates\resolutions\etc.


    For example: i import a bunch of raw MOV files with different framerates, and HEVC (h265) is selected by default. If i go through the list 1 by 1 and select Voukoder, it's fine, but it takes a lot of time. (In fact, i can just start H265 encoding on CPU and it will still finish before NVENC, since i should change encoder for a bunch of files if i want to use GPU for encoding). And if i press ctrl+a and change encoder to Voukoder, it applies the same framerate settings to all selected files.


    Thanks!

    Update: it seems that MP4 file is somewhat broken too: in Google Chrome and VLC it's starting from the second 11 (assuming we're talking about the same file) and keeps increasing file duration as it plays till second 22. Some other programs are not playing it at all.

    Mozilla and MPC behave normally.

    In my experience I had to disable all integrated GPU functionality to get a decent NVENC encoding. I disabled the iGPU completely. It was just slowing down.

    Because it's trying to decode video using iGPU for some reason. At least i've seen this with HEVC NVENC encoding.

    Hey! Another little bug in Voukoder VP9 encoder.


    • Describe the issue as detailed as possible.

    Voukoder VP9 encoder in combination with 2-pass (ABR) strategy and WEBM extension outputs file, duration of which is 2x times more than it should be. In fact, the last video frame is frozen for the duration of that added time. This only happens if 2 pass is checked and only with WEBM container: mp4 works fine.


    • Provide steps to reproduce the issue.

    Import any file, export media: Voukoder, libvpx VP9, ABR 2-pass, WEBM container, other settings irrelevant.

    11 seconds of input video becomes 22 seconds, with 1 last frame of first 11 seconds frozen for the rest 11 seconds.


    Both Premiere 2017 and 2018 suffer from that bug. It's not at all urgent, since mp4 is alright, but might be shocking for a new user :)

    Here's the file that this bug produces.

    Voukoder log is attached.


    Thanks!

    Hey! I've encountered a strange problem with Voukoder and Premiere\ME 2017.

    The problem is - i can't see NVENC options when i try to export files.

    Voukoder log is pretty clear:

    Quote

    [2018-10-04 23:56:17,393589][INFO] Nvenc initialized successfully

    [2018-10-04 23:56:17,393589][INFO] 1 CUDA capable devices found

    [2018-10-04 23:56:17,393589][INFO] [ GPU #0 - < GeForce GTX 1080 Ti > has Compute SM 6.1 ]

    [2018-10-04 23:56:17,461567][INFO] OpenEncodeSessionEx failed: out of memory (10)

    [2018-10-04 23:56:17,489558][INFO] No NVENC capable devices found


    But at the same time, after i close ME 2017 and open ME 2018 it works just fine:

    Quote

    [2018-10-04 23:57:14,641308][INFO] Nvenc initialized successfully

    [2018-10-04 23:57:14,641308][INFO] 1 CUDA capable devices found

    [2018-10-04 23:57:14,641308][INFO] [ GPU #0 - < GeForce GTX 1080 Ti > has Compute SM 6.1 ]

    [2018-10-04 23:57:14,698290][INFO] supports NVENC

    [2018-10-04 23:57:14,745385][INFO] Nvenc unloaded

    Nothing else is changed: it's the same source file, it's the same version of Voukoder (obviously) and only 20 seconds pass after i close 2017 and start 2018 .


    I'm pretty sure it won't be reproduced on your machine: you wouldn't miss NVENC not working, as well as all the other Voukoder users ^^

    The real question is: what can i try to make it work? Is there a way to force it to try using NVENC even if it's "out of memory"?

    I've already tried installing latest drivers and disabling IGD (Intel integrated GPU) - nothing helped.

    I'd gladly use ME 2018, but i have problems with it's installation i've already mentioned: some files are treated as "audio only" for some reason, so i can't...

    Logs for both Premiere versions are attached.


    UPDATE:

    Here's something that i've pulled off Nvidia devtalk:

    I've also just realised it's probably the same bug as this one. But this is strange because i believe i've used Voukoder 0.7 on this very system even before Premiere 2018 existed...


    Thanks!

    Files

    • 2017.txt

      (15.96 kB, downloaded 0 times)
    • 2018.txt

      (15.76 kB, downloaded 0 times)

    Oh that's interesting. I thought it's a simple error when ffmpeg tries to proccess audio stream that doesn't exist. So unchecked "export audio" works fine for you via VP9 encoder?


    Quote

    Does it only occur with 2-pass encodings?

    No, any VP9 encoding if "export audio" is unchecked. The file is actually created and works fine after that, but 2-pass is not creating a file, because it fails at 50%, not at 100% like other 1-pass encoders.


    Quote

    Does it happen with large files / frames?

    Any files and frames. I've tried 4K and 720P, all without sound.


    Quote

    Is your memory usage at its limit during encoding?

    No, it's only 9 out of 16 GB total.


    I've just realised it works fine in Premiere version 2017.1.2 and only bugs in 2018 12.1.1.

    I will try updating to 12.1.2 later to see if it's fine there, since i'm not very content with my 2018 installation anyway (many files not showing video stream, only audio on import, etc...) so...

    I guess it's not a bug at all then.

    Hey! Another bug in Voukoder VP9 export - now a small QoL one.

    • Describe the issue as detailed as possible.

    You can't start exporting file if invalid combination of audio codec and container is set. The problem is that Voukoder actually tries to feed invalid combination to ffmpeg, even if "export audio" is unchecked.

    • Provide steps to reproduce the issue.

    Import any file, export media: Voukoder, libvpx VP9, AAC audio codec with any settings, WEBM container. You'll get an error. And that's actually alright. The problem is you'll get the same error even if you uncheck "export audio" checkbox, and that's not alright. :)


    I'm pretty sure it's related to the previous VP9 bug i've mentioned, so i'm not attaching any logs this time.


    Thanks!

    Hey! I've found a bug in Voukoder VP9 encoder.

    • Describe the issue as detailed as possible.

    Voukoder VP9 export fails at 100% if "export audio" is unchecked with any combination of other settings. The resulting file is playable (maybe the last frame is lost, but i don't think that's actually true) but it renders 2-pass encoding impossible - error is thrown out after first pass, at 50%.

    • Provide steps to reproduce the issue.

    Import any file, export media: Voukoder, libvpx VP9, any settings, uncheck "export audio", export. You'll get an error.


    Voukoder log is attached.

    I imagine it should be pretty easy to fix.


    Thanks!

    Files

    Hey! I'd like to ask you to add some more advanced settings for vp9 when you have time.

    Currently we are missing these:

    -g int (Maximum keyframe interval)

    -auto-alt-ref 0-1 (this one actually requires 2-pass, so only usable for ABR in Voukoder atm)

    -lag-in-frames 0-25 (probably requires 2-pass too, but i'm not sure with this one)

    -sharpness 0-7 (would be a nice addition)


    Thanks!