NVENC funktioniert nicht

  • Im Endeffekt möchte ich folgendes vornehmen:


    Ich habe ein 4k- Video. Dieses Video ist in 60 FPS aufgenommen worden.


    Nach der ganzen Bearbeitung, Schnitten usw... habe ich mich im Internet informiert und habe bis jetzt immer folgende Rendereinstellungen vorgenommen: (Renderer war bis vor Voukoder der Originale Renderer von Adobe)


    Auflösung : Full HD mit 29,97 FPS

    Hacken bei "Maximale Tiefe rendern --> gesetzt


    Profile High , Level 5.1


    VRB Bitrate : 12 - 16 MBit/s

    2 Durchgänge --> ist gesetzt


    Keyframeabstand ist bei 72


    Hacken bei "Maximale Renderqualität verwenden--> ist gesetzt



    So habe ich bis jetzt gerendert.

    Ist das bis jetzt richtig?



    Und bei der Voukoder Version 1.2.1. konnte ich die meisten Optionen so übernehmen.


    Bei der neusten version zeigt er mir folgendes an:


    [09:01:50] Voukoder 2.2.0

    [09:01:50] by Daniel Stankewitz

    [09:01:50] ---------------------------------------------

    [09:01:50] Intel(R) Core(TM) i9-9900K CPU @ 3.60GHz

    [09:01:50] 16 logical cores

    [09:01:50] 32687 MB system memory

    [09:01:50] Display #0 on: NVIDIA GeForce RTX 2080

    [09:01:50] ---------------------------------------------

    [09:01:50] Plugin running in Premiere Pro 13.0.1

    [09:01:50] ---------------------------------------------

    [09:06:32] Loading: translations/english.json

    [09:06:32] Loading: translations/german.json

    [09:06:32] Loading: translations/french.json

    [09:06:32] Loading: encoders/dca.json

    [09:06:32] Loading: encoders/eac3.json

    [09:06:32] Loading: encoders/truehd.json

    [09:06:32] Loading: encoders/aac.json

    [09:06:32] Loading: encoders/ac3.json

    [09:06:32] Loading: encoders/alac.json

    [09:06:32] Loading: encoders/ffv1.json

    [09:06:32] Loading: encoders/flac.json

    [09:06:32] Loading: encoders/h264_amf.json

    [09:06:32] Unloading: encoders/h264_amf.json

    [09:06:32] Loading: encoders/h264_nvenc.json

    [09:06:32] Loading: encoders/hevc_amf.json

    [09:06:32] Unloading: encoders/hevc_amf.json

    [09:06:32] Loading: encoders/hevc_nvenc.json

    [09:06:32] Loading: encoders/libfdk_aac.json

    [09:06:32] Unloading: encoders/libfdk_aac.json

    [09:06:32] Loading: encoders/libmp3lame.json

    [09:06:32] Loading: encoders/libopus.json

    [09:06:32] Loading: encoders/libvorbis.json

    [09:06:32] Loading: encoders/libvpx.json

    [09:06:32] Loading: encoders/libvpx-vp9.json

    [09:06:32] Loading: encoders/libx264.json

    [09:06:32] Loading: encoders/libx265.json

    [09:06:32] Loading: encoders/pcm_s16le.json

    [09:06:32] Loading: encoders/pcm_s24le.json

    [09:06:32] Loading: encoders/pcm_s32le.json

    [09:06:32] Loading: encoders/prores_ks.json

    [09:06:32] Loading: encoders/hap.json

    [09:06:32] Loading: encoders/h264_qsv.json

    [09:06:33] Unloading: encoders/h264_qsv.json

    [09:06:33] Loading: encoders/hevc_qsv.json

    [09:06:33] Unloading: encoders/hevc_qsv.json

    [09:06:33] Loading: encoders/libsvt_av1.json

    [09:06:33] Unloading: encoders/libsvt_av1.json

    [09:06:33] Loading: muxers/matroska.json

    [09:06:33] Loading: muxers/mov.json

    [09:06:33] Loading: muxers/mp4.json

    [09:06:33] Loading: muxers/webm.json

    [09:06:33] Loading: muxers/mp3.json

    [09:06:33] Loading: muxers/opus.json

    [09:06:33] Loading: muxers/ogg.json

    [09:06:33] Loading: muxers/flac.json

    [09:06:33] Loading: muxers/adts.json

    [09:06:33] Loading: muxers/wav.json

    [09:06:33] Loading: muxers/h264.json

    [09:06:33] Loading: muxers/hevc.json

    [09:06:33] Loading: muxers/mpeg2video.json

    [09:06:33] Loading: muxers/mpegts.json

    [09:06:33] Loading: filters/bwdif.json

    [09:06:33] Loading: filters/unsharp.json

    [09:06:33] Loading: filters/yadif.json

    [09:06:33] Loading: filters/zscale.json

    [09:10:17] ---------------------------------------------

    [09:10:17] Export started

    [09:10:17] ---------------------------------------------

    [09:10:17] Frame size: 3840x2160

    [09:10:17] Pixel aspect: 1:1

    [09:10:17] Frame rate: 59.94

    [09:10:17] Interlaced: No

    [09:10:17] Color range: tv

    [09:10:17] Color space: bt709

    [09:10:17] Color primaries: bt709

    [09:10:17] Color TRC: bt709

    [09:10:17] Sample rate: 48000

    [09:10:17] Audio channels: 2

    [09:10:17] ---------------------------------------------

    [09:10:17] Opening codec: h264_nvenc with options: 2pass=1|b=12000000|gpu=0|level=5.1|maxrate=16000000|profile=high|rc=vbr|rc-lookahead=60

    [09:10:17] Failed opening codec: h264_nvenc

    [09:10:17] Unable to open video encoder: h264_nvenc

    [09:10:17] Closing encoders ...

    [09:10:17] Es war nicht möglich den Encoder zu initialisieren.


    Dieser Fehler tritt meinstens bei einer ungültigen Parameterkonfiguration auf.


    Bitte stelle sicher, dass mindestens eine NVENC Sitzung frei ist und schließe alle anderen Programme die NVENC nutzen.


    Bitte überprüfen Sie, ob die verwendeten Optionen und Voreinstellungen mit dem ausgewählten Level konform sind. Sogar die Standardkonfiguration der Encoder (es wurden keine Optionen festgelegt) entspricht möglicherweise nicht allen Leveln.

  • Das Level Flag ist eine limitierung. Manche Decoder wie z. B. alte Handys oder eine PS3 können nicht alle Videodateien dekodieren. Deshalb gibt es das Level Flag um die Voraussetzungen vom Encoder zu limitieren. Lass das Level Flag einfach weg, einfach den Haken bei Level rausnehmen ;)

  • Alles klar, habe ich verstanden. Werde ich gleich nachehr mal probieren :). --> Vielen Dank schon mal dafür :))


    Doch die Settings wie ich sie vornehme, passen ungefähr überein mit denen, die ich im OEM Renderer von Adobe nehme ca überein oder?

  • Eigentlich brauchst du den Haken generell nicht setzen.

    Quelle digitalrebellion:

    Quote

    Maximum Render Quality

    This is a high-quality resize operation that should be used when outputting to a different frame size from your sequence. It can reduce aliasing (jagged edges) when resizing images but is of no use when outputting to the same frame size. This operation significantly increases render times so only use it when resizing.