(Encore) Blu-Ray Compatible File (NVENC)

  • Is this plug-in capable of creating a file that Encore will accept in a Blu-Ray project without trying to re-encode it? I tried checking "Enable Blu-Ray Compatibility Mode" and it didn't help.

  • That would be a great feature to have. I know x264 Pro has a separate format option for blu-ray, so it seems doable. I can find the x264 parameters that Encore wants, there just doesn't seem to be a option to set each of those parameters in the plug-in. I also wonder if it might be the variable framerate issue someone else mentioned. Encore is very finicky.

  • Someone on another forum said these settings work for Encore. Obviously some of these don't need to be exactly the same. It would also be useful to be able to export the files without multiplexing.

    program --pass 2 --bitrate 16000 --stats ".stats" --open-gop bluray --interlaced --pic-struct --level 4.1 --bframes 3 --ref 4 --slices 4 --aud --nal-hrd vbr --b-pyramid strict --keyint 30 --min-keyint 3 --vbv-bufsize 30000 --vbv-maxrate 40000 --weightp 0 --colorprim "bt709" --transfer "bt709" --colormatrix "bt709" --output "output" "input"

  • Encore (at least the old version I have CS5) will only work with closed gop streams. It will accept those encoded with x264 that has --open-gop argument and appear not to re-encode but will just stall. All examples at http://www.x264bluray.com will work with Encore provided --open-gop is omitted.

  • I can not get x264 parameters to match what's needed for BD compatibility. I'm using other x264 encoders (Handbrake and TMPGEnc Video Mastering Works) and matching MediaInfo output. The two fields I can't seem to affect are Max Bitrate (always seems set at 75 Mbps internally somewhere) and VBV Buffer size (always set to 0). BluRays needs Max Bitrate to be <= 30 and VBV to be >0 and at specific ranged values.

    For NVENC based encoding the problems are different but seem to match same issues I have with Mark Weiss's nvenc_export project. Namely BD compatibility fails because VBV Buffer size is wrong ... but not 0 (even though I try and force the buffer size) and the "Max DBP Frames" is 10 vs 4, "Max Re-Order Frames" is 9 vs 1.

    I'm using TMPGenc Authoring Works to do the file validation as if that program says the file is good, Encore does also.

  • I've attached an x264 setting list that was extracted via MediaInfo from files generated Handbrake, voukoder plugin, and TMPGenc Video Mastering Works. Handbrake and TMPG are both accepted by Encore and TMPG Authoring Works without recode.

    Output from TMPGEnc Authoring Works BD Project with file using x264 encoding:


    again, I don't understand why it's 75 Mbps as MediaInfo shows 30 Mbps, so that 75 must be somewhere else in the file.

    and with NVENC encoding (note that nvenc_export also has the 10/9 frame error):


  • I starting playing with another nvenc capable encoder - https://github.com/rigaya/NVEnc/releases/tag/4.10. This developers has exposed just about everything and the generated H264 stream is BluRay compliant. Easiest way to test it is with: http://muldersoft.com/#x264_x64.

    The affected fields are:

    VBV Buffer does not seem to honor the "Buffer Size" parameter. I think it's just not going into the right .

    using the above rigaya encoder setting I couldn't seem to affect the DPB Frame or Re-Order Frame values so those values must be internally. I tried to find an H264 analysis tool that would show these values but wasn't successful in finding the correct location. There is in SPS-VLU a bitstream_restriction_flag and then a num_reorder_frames.

    Log file is attached for the above run.

  • In my journey playing with ffmpeg encoder and enabling the NVENC option, I was able to create valid BluRay steams by adjusting the reference frame, b-frame counts and VBV buffer size. Now your plugin doesn't seem to have a way to control ref frames.

  • Thanks for investigating this. Unfortunately I'm not very much into BluRay authoring, so maybe you can do me a favor and write down a working ffmpeg command line and/or a simple list of ffmpeg parameters that you need in Voukoder?

  • I can confirm that "refs" does work in 1.0 NVENC h264 and gives added control to the generation of BluRay complaint files. There is still a problem with another parameter called "Re-order" frames. See above for where it appears to be located in the video stream. So are you saying that you are tapping off of the ffmpeg I/F to control NVENC? I can "almost" get BluRay compatible output with standalone ffmpeg. At least "re-order" framing is within specs vs at 5. I'm clueless as to what parameter affects this field.

    Attached is command line and output. Hope it helps.

  • Vouk

    Added the Label In Progress
  • Vouk

    Changed the title of the thread from “Encore Blu-Ray Compatible File” to “Encore Blu-Ray Compatible File (NVENC)”.
  • I was more or less able to create BD compatible video with only slight changes to the default settings:


    Opening codec: h264_nvenc with options: b=2250000,bf=2,bluray-compat=1,buffsize=30000000,g=24,level=4,maxrate=3000000,preset=slow,profile=high,rc=vbr,refs=3

    Opening codec: aac with options: b=96000

  • Vouk

    Changed the title of the thread from “Encore Blu-Ray Compatible File (NVENC)” to “(Encore) Blu-Ray Compatible File (NVENC)”.
  • Vouk

    Set the Label from In Progress to Fixed
  • Using 1.0.1 and trying to reproduce your file type above, I was totally unsuccessful. I used your parameters as much as possible.

    3.0 Mbps Max bitrate, 2.5 Mbps VBR rate, 30,000 buffer size, bf=2, ref=3, preset=slow (no difference if set to BluRay), bluray_compat=1.

    for GOP = 12, I get compatible file (sort of)

    for GOP >=15, it blows.

    NOTE also that bufsize parameter changes doVoul_101_12GOP.PNGVoul_101_15GOP.PNG not affect the output, seems totally dependent on max bitrate. << something to look at.

  • [2018-09-07 14:03:44,800738][INFO] Opening codec: h264_nvenc with options: 2pass=1,b=2500000,bf=2,bluray-compat=1,buffsize=30000000,g=15,init_qpB=51,init_qpI=51,init_qpP=51,level=4,maxrate=3000000,preset=slow,profile=high,rc=vbr,rc-lookahead=64,refs=3,strict-gop=1,surfaces=64,zerolatency=1

    I have noticed these changes. Can you try this with as little changes as possible?