Slower encoding after Beta2?

  • I have some problems with the Voukoder speed. Till beta2 it works flawless. Every version after beta2 are much slower for me. Tried every possible settings, including (Use maximum Render quality is disabled). What can I do ?

  • Post by kobol ().

    This post was deleted by the author themselves ().
  • It is not helpful that you cut off parts of the logfile. I added this information because it is necessary to investigate these kind of issues.

    Stay up-to-date and follow me on Twitter. Tell me your feedback.


    Help to improve this plugin and support me on patreon. Thank you.

  • That looks very strange. Sometimes the aRender and aEncoding times are missing right? Also the latencies are very high I think.

  • So your project is like a slide show with PNGs / still images being displayed for some seconds each, right?


    Your average vRender in Vogelforschers 13 lines above is 46ms per frame which equals a theoretical maximum of 22 fps if voukoder would be not involved at all.


    vRender is the time Premiere needs to process frames: decode, apply filters and effects, render everything to the frame buffer. Voukoder has no control over the vRender time.


    What I can't do:

    - Accelerate the rendering process. This is fully under premieres control.


    What I could do:

    - Add variable frame rate (VFR). Very useful for still images but makes problems if you want to re-import that into premiere/other NLEs again. Most people don't like it.


    What I did:

    - Enabled frame caching. Not sure if it helps tough.

    Stay up-to-date and follow me on Twitter. Tell me your feedback.


    Help to improve this plugin and support me on patreon. Thank you.

  • Interesting fact: In beta3 i used an older NVENC SDK. Maybe I should switch to the latest one again. It requires a later nvidia driver again. But it might actually be faster.

    Stay up-to-date and follow me on Twitter. Tell me your feedback.


    Help to improve this plugin and support me on patreon. Thank you.