Vouk's Render Performance Test

  • Nice tool, thanks!

    Here are my results with Premiere Pro CC 2018:

    The FPS don't change when I switch between CPU and GPU (CUDA) decoding in the project settings. According to the Windows 10 task manager, even if GPU decoding is configured, the video decoder of my RTX 2070 is not used.

    But when I play the same source file in a video player GPU video decoding works fine. Very weird that it doesn't work in Premiere Pro.

    edit: I just read that choosing CUDA in the project settings doesn't mean that it will use GPU decoding, so that explains it.

    Edited once, last by cremor ().

  • Interesting. When I open this dialog in my german Premiere Pro CC 2018, that line doesn't mention Intel (or H.264) at all. It's just the german translation of "Enable hardware accelerated decoding".

  • Is it normal that my render speed is not even 1:1 compared to the video length?

    I'll post my results with the tool in a minute.

    EDIT: There are my results...Also I noticed that my GPU only shows load on the "copy" thread in the task manager...How can I fix that?

    My graphics card is an ASUS RTX 2080Ti.

    Also I'm using the BT2020 NCL color space for 4k60 video.

    Edited 3 times, last by SaBeX ().

  • Okay so I tried it now with the BT709 format that I'm recording in using OBS... Forgot that completely. Converting that wouldn't look nicer I suppose. And encoding is faster than the video length now.

    Thanks for the quick reply though!

  • Hi.

    Running the performance test tool i've found out my i7-8700 is able to render at the following rates:

    With Mercury Software Acceleration (general settings + project)

    Using Legacy title: 20fps. Pixel format VUya.

    Without any title, 77fps. Pixel format nv12.

    With Essential graphics titles: 21fps. Pixel format VUya.

    With a 2160p transparent PNG with the text on it: 25fps. Pixel format VUya.

    With a small (text size crop) transparent PNG with the text on it: 34fps. Pixel format VUya.

    With Mercury Hardware Acceleration (general settings + project)

    GTX 1660 goes 100% usage here in task manager, however it is not video encode or decode what is causing the load.

    Using Legacy title: 11fps. Pixel format VUya.

    Without any title, 12 fps. Pixel format nv12.

    It looks we hit a hard limit here for some reason. I didn't try further with this global + project hw enabled.

    Disabling the hw accel option in the project but leaving it enabled in the global preferences:

    Using Legacy title: 25 fps. Pixel format VUya.

    Without any title, 74 fps. Pixel format nv12.

    Exporting 4K video resizing to 1080p with titles: 25fps

    Exporting 4K video resizing to 1080p with titles: 33fps

    Exporting 1080p video: 171fps, pixel format nv12

    Basically I can see that the cpu is somehow limiting me. However, I also see a previous message talking about the pixel format. Is that something I can change somewhere? I went to sequence settings but I wasn't able to find pixel format anywhere.

  • Interesting results with a Ryzen 9 3900X and 1080Ti. The footage is 23.976fps 1080p h.264 from a DJI Osmo. I glued a bunch of short clips together with no effects or transitions.

    Then I ran the export again without closing the export window. The Ryzen 9's massive cache seems to have a slight effect on render speed:

    1. Download it
    2. Copy the PRM file to the plugin folder
    3. Open your project in premiere
    4. Export it and select it on the format selection dropdown box

    Help to improve this plugin and support me on patreon or paypal. Thank you.