Can't export 4k60 video via H.264 NVENC in CC2019 with Voukoder 1.1 and 1.2

  • I previously attempted contact with you via Twitter. I got this issue by running a 4k60 (3840x2160) Prores LT video from an Atomos Ninja Inferno through Voukoder 1.1. I punched in the generic settings for 4k60 from this page:

    https://support.google.com/youtube/answer/1722171?hl=en


    And then got an error "Selector:9 Error Code: 3", which I thought was odd, so I tried updating to 1.2.


    I wasn't previously having this issue with 1080p60 video with the same settings. Haven't tried encoding another 1080p60 video again but I will try again if need be.


    One other important thing to note is that the Export menu is taking a significantly longer time to show up (or sometimes won't show up at all) after I installed the update.


    Please let me know if this is enough.

  • Found this:

    Code
    1. [2019-02-13 02:30:49,430502][INFO] Failed creating CUDA context for NVENC: 0x2cf
    2. [2019-02-13 02:30:49,430502][INFO] No NVENC capable devices found


    Maybe all CUDA sessions are in use? Can you try to close all other GPU based programs?

    Stay up-to-date and follow me on Twitter. Tell me your feedback.


    Help to improve this plugin and support me on patreon. Thank you.

  • Code
    1. [2019-02-13 02:30:50,120418][INFO] Requesting pixel format:
    2. [2019-02-13 02:30:50,120418][INFO] Unsupported pixel format requested:

    Could this be relevant? Maybe nvenc is not compatible with the format/aspect ratio?

    Do you changed the graphics driver?

    And please check for open nvenc sessions this way.

    -> Open command promt or press Win+R

    -> Execute this command WITH the quotes: "c:\Program Files\NVIDIA Corporation\NVSMI\nvidia-smi.exe" encodersessions

    -> Post the output

  • Good point!!


    The pixel format error most likely caused this. Can you please prepare a small example project that causes this error?

    Stay up-to-date and follow me on Twitter. Tell me your feedback.


    Help to improve this plugin and support me on patreon. Thank you.

  • I will try within the next few days, workload is hectic and I don't have a dedicated machine for video encoding.


    It processes when I try to encode it in 1080p, but I'm not sure why 4k isn't working.


    I checked, and the Pascal NVENC should definitely encode 3840x2160 at 60hz. Encoding seems to work with HEVC, so I'll try that tonight and see if YouTube takes it. If it doesn't work, I'll send over a small 4k60 recording for h.264.

  • Vouk

    Removed the Label 1.x
  • Vouk

    Added the Label Not a bug