Premiere Elements 2019 missing NVENC

  • Hi,


    Missing NVENC options under video settings menu. Using Voukoder 1.2.0 and latest Nvidia drivers. Am not running any applications but chrome and premiere elements itself.

    Log attached.


    By the way, the forum won't allow to upload the .log file, so I had to rename it to .txt


    and here is some sessions info from nvidia tool

    the pid is adobe premiere elements 2019 editor - PremiereElementsEditor.exe


  • Hey, Found kind of workaround.


    Before I start the Adobe Premiere Elements 2019, I go to Nvidia Control Panel, add there in the Manage 3d settings sections the APE2019 executable file and set CUDA GPUs to none, click Apply. Then I start the APE2019.

    There are no encoder sessions at this step anymore. At this moment I don't see any NVENC option also in APE2019. Then I go back to Nvidia control panel and set the CUDA GPUs for the APE2019 to All. And wooow, there are an NVENC options to choose. And still no sessions in cmd.

    When I export the file, I see the sessions again for APE2019.

    Export works fine (but the aac part) and there is the GPU load seen.

    After I close and run the APE2019 there is no NVENC option and again sessions are blocked.


    Backported 2017 bug? Or mby you could mange the start-up encoder sessions directly in your plugin?

  • Well.. It is not necessarily a bug. If the host application is reserving a session for certain things it might be intended. It would would be a bad behavior if an application modifies another application.

    Stay up-to-date and follow me on Twitter. Tell me your feedback.


    Help to improve this plugin and support me on patreon. Thank you.

  • You are right. But according to Adobe statements they are not and not going to use NVENC nor GPU for exporting videos. They use it only for rendering during editing.

    So there is no workaround for this on plugin level and to use nvenc I have to go the way I described before? This makes using this plugin pretty problematic, but as we don't have nothing other, we have to accept this solution :( Maybe there is a way to limit sessions? Earlier you mentioned, that 2018 works fine? What if you could compare these two versions to see where is the difference and how to pass it by?


    by the way, thanks for the plugin.

  • I've tried it, it runs too fast and all I see there in command prompt that there are some exceptions, it just doesn't run, gives some errors. I was messing with all this at late night so just ran out of patience and didn't ran this patch directly from cmd :). I'll be at my home place in about 30 minutes and will run this patch again and copy/paste the result here. At least it didn't change the file it had to, as the size didn't change.

  • worked like a charm.

    the exception I saw tonight was about administrative rights:


    Code
    1. Unhandled Exception: System.UnauthorizedAccessException: Access to the path 'GPUFoundation.bak' is denied.
    2. at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
    3. at System.IO.File.InternalCopy(String sourceFileName, String destFileName, Boolean overwrite, Boolean checkHost)
    4. at PatchingDLLFile.PatchingDLL.PatchFile(String sourceFilePath, Byte[] patch1, Byte[] patch2)
    5. at PatchingDLLFile.PatchingDLL.Main()
    6. ^C

    So one must run it with admin rights.