VP9 export fails at 100% if audio export is disabled

  • Hey! I've found a bug in Voukoder VP9 encoder.

    • Describe the issue as detailed as possible.

    Voukoder VP9 export fails at 100% if "export audio" is unchecked with any combination of other settings. The resulting file is playable (maybe the last frame is lost, but i don't think that's actually true) but it renders 2-pass encoding impossible - error is thrown out after first pass, at 50%.

    • Provide steps to reproduce the issue.

    Import any file, export media: Voukoder, libvpx VP9, any settings, uncheck "export audio", export. You'll get an error.


    Voukoder log is attached.

    I imagine it should be pretty easy to fix.


    Thanks!

  • I imagine it should be pretty easy to fix.

    These are the hardest ones. It works for me and i can't reproduce it.


    • Does it only occur with 2-pass encodings?
    • Does it happen with large files / frames?
    • Is your memory usage at its limit during encoding?

    Stay up-to-date and follow me on Twitter. Tell me your feedback.


    Help to improve this plugin and support me on patreon. Thank you.

  • Vouk

    Hat das Label In Bearbeitung hinzugefügt
  • Oh that's interesting. I thought it's a simple error when ffmpeg tries to proccess audio stream that doesn't exist. So unchecked "export audio" works fine for you via VP9 encoder?


    Zitat

    Does it only occur with 2-pass encodings?

    No, any VP9 encoding if "export audio" is unchecked. The file is actually created and works fine after that, but 2-pass is not creating a file, because it fails at 50%, not at 100% like other 1-pass encoders.


    Zitat

    Does it happen with large files / frames?

    Any files and frames. I've tried 4K and 720P, all without sound.


    Zitat

    Is your memory usage at its limit during encoding?

    No, it's only 9 out of 16 GB total.


    I've just realised it works fine in Premiere version 2017.1.2 and only bugs in 2018 12.1.1.

    I will try updating to 12.1.2 later to see if it's fine there, since i'm not very content with my 2018 installation anyway (many files not showing video stream, only audio on import, etc...) so...

    I guess it's not a bug at all then.

  • Vouk

    Hat das Label von In Bearbeitung auf Kein Bug geändert
  • Hi

    Thanks for your work !


    I gave a try to your plugin because I needed a h264 export in Premiere Pro 2018.

    Unfortunately, I mostly need to export without audio (but I cannot mute my audio tracks as I do others exports with audio...)

    So I unchecked the "audio export" as Ayokeito did (configuration attached "h264-preset.jpg")

    And got the same error: most of the video is exported, but there seems to be an error in the last frame(s?).


    Below is the log of the low-level exception - in french but should be ok :)


    Hope you can reproduce it and fix it easily...

    At your disposal if you need to do tests.

    Thanks !


    ------------------------------------------------------------

    10/18/2018 06:59:37 PM : Échec du codage

    A low-level exception occurred in: Voukoder 1.1.0 (Exporter:9)


    Erreur lors de l’exportation

    Erreur de compilation vidéo.


    Une exception de bas niveau s’est produite.


    Écriture avec l’exportateur : Voukoder 1.1.0

    Autour du code temporel : 00:03:43:21

    Composant : Voukoder 1.1.0 de type Exportateur

    Sélecteur : 9

    Code d’erreur : 3

    ------------------------------------------------------------

  • Here we go: I left the 2 last encodings:

    - the first (18.06 \DamnDisMoi AUDIO.mp4) is with Audio and went OK

    - and the second (18:44 \DamnDisMoi NO AUDIO.mp4) is without Audio and failed.

    Thanks a lot !

  • Hi

    Thanks for the new releases.

    I gave a try to Vokouder 1.1.3, and the bug is still present:

    the export in Premiere Pro CC2019 fails if "export audio" is unchecked (same error).

    So unfortunately I still cannot use Vokouder for my needs, so if a fix comes to your mind...

    Thanks !

  • Hi

    I guess it's not a priority, but just for the record, the problem is still here with Vokouder 1.2.1: export with disabled audio always fails.

    It's ok I can do it with x264vfw, but would be greater with vokouder :)

    Thanks !